Color banding and animation issues with 520.56.06

Still persists on 525.60.11
515 does not have the issue and looks great.

AOC AG241QG - Tried on both DP-4 and DP-2
Pop!_OS 22.04
nvidia 525.60.11

I have noticed on 515 there is no visible change on screen when toggling dithering on/off. on 520 and 525 there is an immediate change in color on the screen.

Please let me know if there is any other info I should collect and if there is a need to post this in a new thread for 525.

1 Like

Same problem here :(

1 Like

Apparently, I can now finally reply. Tried to upgrade to the newest driver today, but the issue persists. So I think that it is safe to say that this bug affects both 520.56.06 and 525.60.11. 515.76 still works correctly tho.

Just wanted to say that this is probably related to the high refresh rate. Because most people who experience it have a high refresh rate monitor and the issue gets progressively worse the higher refresh rate you set. (60hz - basically unnoticeable; 240hz - horrible)

After installing the 525 driver I had a lot of problems with one of my systems. For some reason the driver changes some settings in the Dithering Controls section. With the 515 series I had all the options on Auto which causes no problems at all.

After I installed 525 I had to mess with the settings because I noticed glitches when dragging a window. I had to change Dithering to enabled and Depth on 8 to fix that problem, however when I use 525 I get a lot of color banding. Another problem that I noticed is that if I go to the Information tab the new driver only used 2 lanes instead of 4? Also I believe that the new driver is messing with the color settings. I reverted back to 515.

Ubuntu 22.04 LTS with kernel 5.15
RTX 3050

We were able to duplicate issue locally and working on the fix.
Shall confirm once driver is released publicly with the fix.


Does the new 525.85.05 Release include a fix for this issue?

for those who are wondering the new 525.85.05 driver not fixed the issue

Issue has been root caused and fix will be incorporated in future released driver.


I am very happy to hear that and waiting for next release :)

In 99.9% of all cases, “future release” and “next release” does not mean the same …

@amrits Tell us - in months - how long we have to wait for this fix. And will it fix my problem (mentioned above) as well ?

1 Like

Fix will be available in next upcoming released driver.


I can confirm that this has been fixed in 525.89.02, and everything seems to work fine. Thanks for the fix.

Same here, thanks for the fix :)

I admit, it is better but in the darker places are still pixel artifacts :( I think in previous drivers (before the issue this pixel artifacts wasn’t there)
current driver 525.89.02
Linux-x86_64 (manjaro Gnome version)

3440 x 1440 120Hz GSync Enabled - via Display port
CPU: AMD Ryzen 7 2700X (16) @ 4.000GHz
GPU: NVIDIA GeForce GTX 1050 Ti
Asus PRIME x470PRO

Nvidia setings: Dithering, Mode, Depth on auto [enabled,None,8bpc] [I have more screen shots but can’t add ]:

While looking at it closely, I see that unfortunately, you are right. It’s very slight, but it’s there. At least it is usable now. Still, it would probably be better to investigate.

Still, it would probably be better to investigate.

Yes, look at this. Dropbox - File Deleted - Simplify your life is after the fix :/
When The Witcher 3 has loading screen there are artifact also - bigger than I’ve presented

@amrits Could You check please?

1 Like

I just updated to 525.89.02 here in Ubuntu 22.04.2 LTS with the “Proprietary GPU Drivers” PPA. It seems like the issues I reported here are gone.

Thanks for the update.

Updating to 525.89.02 fixed the banding issues but brought back random freezes. Oh well, time to google that GPU clock kludge again and see if that helps :)

After updating to 525.85.05 this issue still persists for me.

With dithering disabled in Nvidia X Server Settings, I get ugly banding in gradients, with dithering enabled, the gradients look OK. I tried my best to capture this with my phone.

The problem with this is that with dithering enabled, I see moving patterns in dark areas that look almost like moire patterns. I use my PC mostly for programming in a dark IDE and this is very distracting. Unfortunately this is almost impossible to demonstrate. It is barely visible on camera if you don’t know what to look for, because filming an LCD screen is hard. And obviously it does not show up on direct screen recordings. I will try and obtain some kind of HDMI capture device to record it.

Turns out I am an idiot and confused 85 and 89. Waiting for 89 to show up on Ubuntu then.

The color banding / distortion problems I encounter (see other thread above), are not solved by this new driver at all :(