Compilation error in WRF 4.1.2


I’m trying to compile WRF 4.1.2 (dmpar), with pgf90 and gcc (option 3).

The versión of pgf90 is:

pgf90 19.7-0 LLVM 64-bit target on x86-64 Linux -tp haswell

The only compilation error found in the log.compile file is:

PGF90-F-0000-Internal compiler error. mark_ilitree: visit != val 0 (module_ra_goddard.f90: 9873)
PGF90/x86-64 Linux 19.7-0: compilation aborted
3.38user 0.15system 0:03.64elapsed 97%CPU (0avgtext+0avgdata 36128maxresident)k
0inputs+59496outputs (0major+37482minor)pagefaults 0swaps
make[3]: [module_ra_goddard.o] Error 2 (ignored)

I would appreciate any suggestion.

Thanks in advance


Do you get the same error if you choose pgf90 and pgcc (option 54)? I managed to get it to compile with that. All ICEs are essentially bugs. I’m compiling it now as option 3 to see if I can track down where the ICE comes from. And I’m guessing that since this dmpar, you’re building with OpenMPI or some other MPI variant?

Thanks for the reply.

I’m using mpich-3.3.1, compiled with the same versión of PGI.

If I use option 55 (pgf90 & pgcc) and I have exactly the same Error.

Let me know if you need further information.

Best regards.


I was able to download WRF 4.1.2 and reproduce the error. I added a problem report (TPR#27672) and sent it to our engineers for further investigation.

The error does appear to be new in 19.7 since I’m able to successfully compile the same source with PGI 19.5. I’ve also determined that the source compiles fine with our non-LLVM compilers. Hence as a work around, can you try either compiling with PGI 19.5 or set your PATH to our non-LLVM compilers ($PGI/linux86-64-nollvm/19.7/bin)?

Thanks for the report!

Hi Mat,

I’ve downloaded and installed PGI 19.5, and with this compiler versión WRF 4.1.2 has been compiled successfully.

Thanks for your support!


I can confirm this error still exists with pgfortran 19.10-0 LLVM 64-bit compiling WRF-4.1.3.

Any new ideas since the last posting?

Correct, we weren’t able to get a fix in place for 19.10, but the issue should be address in our 20.1 release.


Should be corrected w/20.1

I am using the community version (19.10) and I have the same ICE. I guess the next community version will not be release until later this year. Is there a way for me to use an older version like 19.5 so I can compile WRF4.1? Or is there another way to get around the problem?

Hi Ssoong,

No, archived releases are only available to Professional Edition License holders.

Note that PGI 20.4 is the last PGI branded release. We’re transitioning the compilers to be part of the NVIDIA HPC SDK will be available for early access here soon (see . The first NV 20.5 early access release will have the fix for building WRF 4.1.2. There’s no cost but does require registration. If you are unable to register, we will have twice yearly releases that do not require registration, with the first late this year.

Best Regards,