Compiler Error MSB3721 with Cuda 6.5 and VS 2013

Hello Team,

I am Compiling one application with cuda 6.5 and VS 2013 and i am getting the issue-

Error 112 error MSB3721: The command ““C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v6.5\bin\nvcc.exe” -gencode=arch=compute_30,code=“sm_30,compute_30” -gencode=arch=compute_35,code=“sm_35,compute_35” -gencode=arch=compute_37,code=“sm_37,compute_37” -gencode=arch=compute_50,code=“sm_50,compute_50” -gencode=arch=compute_52,code=“sm_52,compute_52” -gencode=arch=compute_60,code=“sm_60,compute_60” -gencode=arch=compute_61,code=“sm_61,compute_61” -gencode=arch=compute_70,code=“sm_70,compute_70” --use-local-env --cl-version 2013 -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin\x86_amd64” -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v6.5\include” -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v6.5\include" -G --keep-dir x64\Debug -maxrregcount=0 --machine 64 --compile -cudart static -I. -g -DWIN32 -DNDEBUG -D_LIB -D_MBCS -Xcompiler “/EHsc /W3 /nologo /Od /Zi /RTC1 /MDd " -o x64\Debug\collision_engine_derived.cu.obj “C:\Users\Pradeep\Desktop\tuka_cloth-simulator_Texture\Clothsim\solvers\collision_solver\collision_engine_derived.cu”” exited with code 1. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\BuildCustomizations\CUDA 6.5.targets 593 9

Please help me to solve this issue.

Suggestion: The MSB3721 error is not useful for understanding what is wrong. The actual error from nvcc should precede this. If it does not, you need to increase the verbosity on Visual Studio to see the nvcc-reported error.

You can easily discover how to increase the verbosity on visual studio by googling for that. It is covered in various places on the web.

Regarding what you have shown, you are attempting to build a project that is/was expecting a newer CUDA version.

For example, CUDA 6.5 doesn’t know anything about sm_60, sm_61, and sm_70. Those GPU architectures came out after CUDA 6.5 was released. You need to be sure to specify only GPU architectures that CUDA 6.5 recognizes. Also, if you are using CUDA 6.5 because you have a very old GPU that is not supported by newer CUDA versions, you may be wasting your time with this effort. Make sure the actual architecture of the GPU you intend to run on is in the list. Stated another way, if your GPU is sm_30 or newer, you should probably update your CUDA version to a more recent version, like CUDA 9 or 9.1

Thanks txbob,

I tried in VS 2015 with cuda 9.1 and getting the same error MSB3721.

My code is working fine with the VS2010 and cuda 4.2, when i am updating my project with the VS 2013 cuda 6.5 with graphics card NVIDIA GeDorce GTX 970 then i am getting the above error.

Same error i am getting with Different Graphics Quadro M1200 VS15 and cuda 9.1.

Please Help me to resolve this issue.

You’ll need to increase the verbosity as I already indicated.

Thanks txbob,

I will follow .