Complie problem of PGI 7.0 for NCAR Graphic

Dear Sir,

I am using NCAR graphics with newly purchase PGI 7.0.
I have been used PGI 6.1, there was no problems.

The setting with PGI in /etc/csh.cshrc on REDHAT 9.0

setenv PGI /opt/pgi
setenv NCARG_ROOT /usr/local/ncarg
setenv LM_LICENSE_FILE $PGI/license.dat
setenv LD_LIBRARY_PATH $PGI/linux86/7.0/lib
setenv RIP_ROOT /home/cmaq4_5_m/mm5_m/RIP4
setenv PAVE /home/cmaq4_5_m/Model3_program/pave_v2.3
set path=(./;/usr/lib;$PGI/linux86/7.0/bin;/home/cmaq4_5_m/lib/netCDF/bin;$path)
set path=(./;$PAVE;/$PGI/linux86/7.0/mpi/mpich/bin;$NCARG_ROOT/bin;$NCARG_ROOT/lib;$NCARG_ROOT/include;$path)

When I run the “idt”, the error message is

idt: relocation error: /opt/pgi/linux86/7.0/lib/ undefined symbol: __pgi_trace

Please let me know what the problem was…

Thank you in advance…

Did you recompile everything? Some version of the 6.x compilers had a __pgi_trace symbol. This has been changed in later compilers. You should really recompile when changing major version numbers.

I tried with re-comple NCAR graphic…
It didn’t work…

I also tried with old PGI 6.1, It worked fine…

But with PGI 7.0, It didn’t work…

Is there problem with PGI 7.0 for NCAR graphic???

Should I go back to PGI 6.1 if I want to use NCAR graphic???

Please let me fix the problem…

Thank you…

Hi Gold,

My guess is that you’re using gcc to link idt. Try either using pgcc or add the linker script “/opt/pgi/linux86/7.0/lib/pgi.ld” to you link options.

The “__pgi_trace” symbol was added as of the 6.2 release in order to support on demand trace back debugging. Unfortunately, this addition has caused some compatability issues with non-PGI compilers.