Compute-sanitizer fails when running from inside a container


I’m trying to make some GPU memory test run in docker. Although my test pass on the host, they don’t when running in docker.
I get these kind of errors :

========= Program hit named symbol not found (error 500) on CUDA API call to cuGetProcAddress.

The container is ran from gitlab-ci, in privileged mode, with NVIDIA_DRIVER_CAPABILITIES=all. I tried the solution from this link : Running compute-sanitizer within a docker container which consisted in adding a few docker flags, but the result did not change.

Is there a documentation hidden somewhere with tips about how to run compute-sanitizer properly in docker ?

These API errors are typically generated when the runtime used is newer than the driver.

They can be ignored using the --ignore-getprocaddress-notfound option.


Thank you for the tip. I resolved my problem by upgrading the driver, even so on the paper it did support the cuda version I was using. Everything works now.