CONNECTING RASPBERRY PI WITH JETSON

Hi
I m trying to connect jetson tx2 and raspberry pi 3 with CAT.5E ethernet cable
But they are not recognizing each other

here are some command outputs

JETSON TX2

nvidia@tegra-ubuntu:~$ ifconfig -a
docker0 Link encap:Ethernet HWaddr 02:42:66:9d:88:8c
inet addr:172.17.0.1 Bcast:0.0.0.0 Mask:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

dummy0 Link encap:Ethernet HWaddr de:87:cf:de:99:2c
BROADCAST NOARP MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

eth0 Link encap:Ethernet HWaddr 00:04:4b:a5:67:5c
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:396948 errors:0 dropped:0 overruns:0 frame:0
TX packets:566 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:23827056 (23.8 MB) TX bytes:111218 (111.2 KB)
Interrupt:42

l4tbr0 Link encap:Ethernet HWaddr 62:88:5a:cc:60:ce
inet addr:192.168.55.1 Bcast:192.168.55.255 Mask:255.255.255.0
inet6 addr: fe80::3ce6:61ff:fe92:5d42/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:579 (579.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:753 errors:0 dropped:0 overruns:0 frame:0
TX packets:753 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:55222 (55.2 KB) TX bytes:55222 (55.2 KB)

tunl0 Link encap:IPIP Tunnel HWaddr
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

usb0 Link encap:Ethernet HWaddr ae:0d:77:74:08:85
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

usb1 Link encap:Ethernet HWaddr 62:88:5a:cc:60:ce
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr 00:04:4b:a5:67:5a
inet addr:192.168.1.11 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::edf1:1b4a:5d22:a3b2/64 Scope:Link
inet6 addr: fdf8:113:d31f:ca00:7931:2780:187a:e8c8/64 Scope:Global
inet6 addr: fdf8:113:d31f:ca00:98e2:2167:d17c:6330/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:172999 errors:0 dropped:0 overruns:0 frame:0
TX packets:374822 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:24218387 (24.2 MB) TX bytes:259778982 (259.7 MB)

nvidia@tegra-ubuntu:~$ dmesg|grep eth0
[ 10.036781] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 10.045417] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 661.266822] eqos 2490000.ether_qos eth0: Link is Up - 100Mbps/Full - flow control rx/tx
[ 661.276050] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 666.869803] eqos 2490000.ether_qos eth0: Link is Down
[ 759.890528] eqos 2490000.ether_qos eth0: Link is Up - 100Mbps/Full - flow control rx/tx
[ 1480.405250] eqos 2490000.ether_qos eth0: Link is Down
[ 1535.238779] eqos 2490000.ether_qos eth0: Link is Up - 100Mbps/Full - flow control rx/tx

nvidia@tegra-ubuntu:~$ sudo arp-scan -l
ioctl: Cannot assign requested address
WARNING: Could not obtain IP address for interface eth0. Using 0.0.0.0 for
the source address, which is probably not what you want.
Either configure eth0 with an IP address, or manually specify the address
with the --arpspa option.
Interface: eth0, datalink type: EN10MB (Ethernet)
ERROR: Could not obtain interface IP address and netmask
ERROR: pcap_lookupnet: eth0: no IPv4 address assigned

RASPBERRY PI

pi@raspberrypi:~ $ ifconfig -a
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 10.42.0.10 netmask 255.0.0.0 broadcast 10.255.255.255
inet6 fe80::ba27:ebff:fecd:da5a prefixlen 64 scopeid 0x20
ether b8:27:eb:cd:da:5a txqueuelen 1000 (Ethernet)
RX packets 447 bytes 98212 (95.9 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 420013 bytes 21014601 (20.0 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 18 bytes 1048 (1.0 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 18 bytes 1048 (1.0 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.3 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 fe80::dc77:16fa:f84e:cc58 prefixlen 64 scopeid 0x20
inet6 fdf8:113:d31f:ca00:2b5f:430b:d6f2:d47c prefixlen 64 scopeid 0x0
ether b8:27:eb:98:8f:0f txqueuelen 1000 (Ethernet)
RX packets 9686 bytes 2018494 (1.9 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 12001 bytes 3885889 (3.7 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

pi@raspberrypi:~ $ dmesg|grep eth0
[ 1.753125] smsc95xx 1-1.1:1.0 eth0: register ‘smsc95xx’ at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:cd:da:5a
[ 5.762110] smsc95xx 1-1.1:1.0 eth0: hardware isn’t capable of remote wakeup
[ 5.762264] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 502.508070] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 502.513060] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1
[ 508.100495] smsc95xx 1-1.1:1.0 eth0: link down
[ 601.134054] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1
[ 1321.636443] smsc95xx 1-1.1:1.0 eth0: link down
[ 1325.533698] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1
[ 1371.612445] smsc95xx 1-1.1:1.0 eth0: link down
[ 1376.485852] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1

pi@raspberrypi:~ $ sudo arp-scan -l
Interface: eth0, datalink type: EN10MB (Ethernet)
Starting arp-scan 1.9 with 16777216 hosts (http://www.nta-monitor.com/tools/arp-scan/)

and it just stays like this

Both raspberry and jetson connects to my pc with the same cable

Do i need to configure anything?
Thanks

Are you using the standard wired ethernet connectors on both ends? If so, perhaps one isn’t auto detect and it needs to be wired as “crossover”:
https://en.wikipedia.org/wiki/Ethernet_crossover_cable

If even one port can auto-detect the need for crossover, then no special steps are needed. If both ports involved cannot work with auto-detect of crossover, then manual wiring changes are required. If you are going through an ordinary switch, then no wiring change should be required…only direct wiring would ever care.

Hi
Yes i m connecting same ethernet cable at both ends of jetson and raspberry
How can i check for auto-detect or enable it?

Most modern desktop PCs can auto detect if crossover is required. I don’t know if this is part of the TX2, nor do I know if the RPi has this. On the other hand, whether or not auto detect for crossover exists, it will never hurt to use a crossover cable directly between two ethernet cards when there is no intervening switch. Since you are not using a switch, I suggest just going straight to a crossover.

The crossover cable is the same as a regular cable, but the TX and RX are swapped. Many shops which supply ethernet cables have “crossover” cables available as well, but you’d have to search for this.