Could not open nvidia-settings (You do not appear to be using the NVIDIA X driver)

I have been working my way out of installing nvidia drivers for my ubuntu 16.04 for a long time but am not able to complete it somehow. I’ve searched almost the entire web but with no affirmation on correct process whatsoever so raising here is my last resort.

I’ve installed Nvidia 367 through .run file from the official driver page by following these instructions,-CUDA-7,-cuDNN-3). But after everything is complete i’m unable to run nvidia-settings on my system as this shows me the error:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server

I tried the above mentioned process but nothing happened. On my console it shows

nvidia-settings could not find the registry key file. This file should
have been installed along with this driver at
/usr/share/nvidia/nvidia-application-profiles-key-documentation. The
application profiles will continue to work, but values cannot be
prepopulated or validated, and will not be listed in the help text.
Please see the README for possible values and descriptions.

I can go on about telling all the procedures i’ve been trying on the web for 4-5 days where nothing seems to happen. How can i just make this nvidia-settings work/run? I’ve also tried understanding the code which is showing this error (on github, nvidia-settings repo) if it could resolve anything out but ofc nothing helped.

Is it because optimus is still not totally supported by nvidia for linux and i need to use a third party software (bumblebee) to resolve this (my card has optimus support)? Is running prime-select nvidia going to help in any way?
Also i don’t want to install Nvidia through package manager as i’ll need CUDA 8 installation later again through .run file so want to keep things consistent.

So how can i make this nvidia-settings finally work on my system (after installing through .run file as people seem to be able to run it through nvidia-367 package installation (i.e it runs fine if installed through apt-get). Is there anything i’m missing for this?)

Here’s my system specification:

00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
Subsystem: Lenovo 4th Gen Core Processor Integrated Graphics Controller [17aa:380a]
Flags: bus master, fast devsel, latency 0, IRQ 31
Memory at b5000000 (64-bit, non-prefetchable)
Memory at c0000000 (64-bit, prefetchable)
I/O ports at 6000
Expansion ROM at [disabled]
Kernel driver in use: i915
Kernel modules: i915

07:00.0 3D controller [0302]: NVIDIA Corporation GK208M [GeForce GT 740M] [10de:1292] (rev a1)
Subsystem: Lenovo GK208M [GeForce GT 740M] [17aa:380a]
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at b3000000 (32-bit, non-prefetchable)
Memory at a0000000 (64-bit, prefetchable)
Memory at b0000000 (64-bit, prefetchable)
I/O ports at 4000
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

uname -r

i can provide more information xorg.conf etc if needed. This will likely help others as well in resolving this problem (or tell me if there’s any better place i can resolve this perhaps a mailing list etc). But just please help me in this.

Here are the asked logs attached.

Also i can see “is nvidia enabled:no” in gpu-manager.log. Is it the cause? Thanks.

nvidia-installer.log (2.3 KB)
nvidia-bug-report.log (260 KB)
gpu-manager.log (2.16 KB)