Could not show Constant Buffer View & Texture

Hello,I get a bug when using Nsight(visual studio edition) to debug dx12,I could open the nsight and the succeefully captured the application,however, I can’t get the useful information from the result.
I,For all drawcalls,the geometry part will show:“renderig geometry failed”.
II,The API Inspector also have alot of bugs.for example:
1,The Nsight could not find cbufferview and shader resource view in VertexShader stage.
2,The SystemValueType of input parameters always show “D3D_NAME_UNDEFINED”.
3,The ShaderResourceview in PixelShader stage could show successfully,but I can’t get the detail information such as check the texture or descriptor distribution.Trying show texture will get an error string:“Failed texture creation: Could not retrieve data”.
I have tried to use nsight to debug some sample demos from microsoft and get the same result.
This is my environment:
OS:win10.0.17763.1 (rs5_release).
VS:vs2017.
GraphicCard: RTX2080.
CPU:I7-8700K.
Nsight:NVIDIA_Nsight_Visual_Studio_Edition_Win64_6.0.0.18296
Driver:418.91-desktop-win10-64bit-international-whql
It seems that the Nsight could not transform resources to thier real type(cbuffer view,shader resource view and so on) after capture and this bug only appeared in my pc, some old pc with old windows and driver could successfuly use nsight to debug dx12.
I’d like to know the reason why I failed to check cbuffer and shaderresource from capture result.If it’s my own promplem or a common problem.
Thanks for your assistance(≧∇≦).

Hello!

Sorry that you are running into this issue. Could you try using Nsight Graphics? It’s been updated a bit more recently and may have the fix for your issue.

https://developer.nvidia.com/nsight-graphics

If this doesn’t solve your issue, please report back and we will get a bug filed for you ASAP.

Thanks,
Seth

I tried the latest Nsight Graphics and the problem was solved, very thanks for your answer(≧∇≦)

Awesome! Glad to hear it worked. :)