CPU occupancy rate is 100% for vi-output progress of camera

Hi,all:

Jetpack: 5.1.0

When I open the camera with the following command:
v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=UYVY --set-ctrl bypass_mode=0 --stream-mmap --stream-count=1000000 --stream-to=/dev/null -d /dev/video0
There is a vi-output process with 100% cpu usage.

So how do I fix this?

hello 1627226101,

Jetpack-5.1/ r35.2.1 is not quite stable,
is it possible for moving to the latest release version, i.e. JetPack 5.1.2 for confirmation?
you may see-also Release Notes (35.4.1).

Hi,JerryChang:

I tried it on jp5.1.2 and the phenomenon is the same.When I execute the command, the camera is working properly,but there will be 100% vi-output occupancy.

hello 1627226101,

please refer to Verifying the V4L2 Sensor Driver to examine your sensor driver,
could you please double check $ v4l2-ctl -d /dev/video0 --list-formats-ext.
you should assign the sensor supported settings to the pipeline for testing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.