CPUs not used

Hello,

I noticed that 2 cpus were inactive after flashing my board so I modified the power mode to use all 6 using “sudo nvpmodel -m 0” but now the 2 cpus are indicated as running but i see no action on them using jtop: they remain at 0%

How can I correct this behavior?

Thanks,

There is an argument being passed to the kernel, “isolcpus=1-2” doing this (check “cat /proc/cmdline”). You can remove or disable the isolcpus to prevent that behavior.

There is more than one way to achieve this, and probably editing “/boot/extlinux/extlinux.conf” is the simplest way (although there may be people may need to edit the device tree). See:

Hi,
The two Denver cores are not scheduled any task due to a performance concern. Please refer to:
https://elinux.org/Jetson/L4T/r32.4.x_patches
[TX2] Denver cores not working on TX2

If you would like to use the cores, please utilize taskset.