Creating URDF in Isaac Sim, importing to Isaac Gym

As I saw in the Isaac sim tutorial, there are 3 options for importing a robot model to the simulation environment, URDF, STEP files and Onshape, Creating a URDF from scratch is time consuming but using STEP file and Isaac sim GUI looks like a faster option, I’m wondering if I can use Isaac sim to create the robot and then save it as a URDF and then import it to Gym?
[I haven’t installed the sim or gym as I’m still waiting for my PC to arrive and can test them]

I had the same question and found a few solutions
I used webots robot simulator and was able to import my robots as urdf but there are some errors
also you can edit in blender with phobos plugin
I needed to make some edits to the urdf file to set the joint limits correctly.
you can also import into isaac SIM but I didnt want to install SIM at present

was able to get a working version that articulates with joint monkey andI was able to modify the anymal example in isaac-envs to train my robot (badly so far!)

hope that helps


Thanks, I installed Isaac SIM and tested it, you can only export as USD file not URDF, so in the future when Isaac GYM can import USD files it would be possible to design in SIM and bring it to GYM. There is also a Solidworks URDF exporter which is not the best option but better than nothing.

Hi, I found a message in the Isaac gym USER GUIDE :Gym currently supports loading URDF, MJCF, and USD file formats. Loading an asset file creates a GymAsset object that includes the definiton of all the bodies, collision shapes, visual attachments, joints, and degrees of freedom (DOFs). Soft bodies and particles are also supported with some formats.
Does this mean that gym can import USD now?

No, as I remember from another post Nvidia team said that’s a mistake in the documents, current release doesn’t support USD files. I saw in another post that Gym is going to be part of Sim so we will get this feature naturally.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.