Cross Compiled Binary is Not Running on Jetson Nano


I have been trying to compile binary for Jetson Nano (4GB) on my host machine which is an Ubuntu 20.04 distribution. I have tried my hands on over vectorAdd example and following are the steps which I followed to create two binaries:

  1. Binary 1 - To run on host machine i.e. Ubuntu 20.04
    Inside the vectorAdd sample directory on host:
    Command - make
    Result - Binary executed correctly, result was pass.

  2. Binary 2 - To run on Jetson Nano
    Inside the vectorAdd sample directory on host:
    Command - make TARGET_ARCH=aarch64 TARGET_OS=linux SMS=“52 53” HOST_COMPILER=/usr/bin/aarch64-linux-gnu-g++
    Result -
    [Vector addition of 50000 elements]
    Failed to allocate device vector A (error code initialization error)!

I have tried many permutation and combination of different parameters but still unable to run binary on Jetson Nano.

Tried NVCC command as well:
nvcc -m64 -arch=compute_53 -code=sm_53 -target-dir=aarch64-linux --compiler-bindir=/usr/bin/aarch64-linux-gnu-g++ -o vectorAdd

But still the result remains same. Binary is not able to invoke the GPU.

Can anyone please state me the problem so that I can look at that specific area and sort this out.

Alark Mishra


Can any one please help me over this topic. I am unable to resolve it.

Thanks in advance !
Alark Mishra