Cross compiling with CUDA toolkit 6.5 for Jetson -> runtime version > driver version

I cross compiled a large project on Ubuntu 1404 with the new CUDA 6.5 Toolkit with cross compilation tools. When executing the appliation I discovered that “CUDA runtime version is newer than the driver version” hence CUDA commands could not be executed.

Normally on a PC I would simply update for the latest graphics driver, but there is now such solution here, is there? Hence I began looking if there was a Jetson TK1 toolkit for 6.5 (surely the driver in that package would fit the toolkit), turns out that ones is not out yet “Available soon”:
https://developer.nvidia.com/cuda-downloads

So then I thought that perhaps it’s easier to just revert to the 6.0 toolkit on my PC (where I do the cross-compile), but it could not find a CUDA toolkit deb package for ubuntu 1404? Is my only option to downgrade to Ubuntu 1204 and run the 6.0 toolkit until the L4T CUDA 6.5 driver comes out?

Try installing the .run on 1404: http://developer.download.nvidia.com/compute/cuda/6_0/rel/installers/cuda_6.0.37_linux_64.run

The .run packages are relatively distro-independent (they’re only different between x86_64, x86, and armv7). NVIDIA only recently began distributing the DEBs and RPMs.

will give it a go…

Btw, when i just run “sudo apt-get install cuda” it seemed install a working driver even though i had not turned off the desktop (ex sudo service lightdm stop), is that a correct assumptions?

Would I need to turn off the desktop before running the *.run aswell?

thanks,

so I ran:

sudo service lightdm stop
sudo sh cuda_6.0.37_linux_64.run

-> driver installation failed
-> current driver broken :(

Anyone know a good way to fix a broken display driver from CLI?

FYI, I think 6.0 is the newest available CUDA driver on Jetson (32 bit/ARMv7). This topic keeps popping up. Try downgrading to 6.0 on your compile host…can’t mix 6.5 and 6.0.

yes the runtime of 6.5 is newer than that of 6.0 and hence the driver does not support it.

So while downgrading (actually adding 6.0 side by side with 6.5 toolkit) i mistakenly tried installing the 6.0 driver which failed to install. Now my display driver is broken :-/

I’m guessing that since I’ve downloaded the Cuda-6-0…run file I could perform a successful driver install from that package if I just knw that procedure, google is my friend :-)

If your display driver failure is not on Jetson, I’m not sure where to start. If you mean display failure is on Jetson, start by serial port or ssh login and run this, see if packages are ok:

sha1sum -c /etc/nv_tegra_release

If one of those fails on Jetson, see:
https://devtalk.nvidia.com/default/topic/775070/embedded-systems/notice-on-apt-get-upgrade-libglx-so-corruption/

Yeah the driver failure is on my host machine that is performing my cross compilation.

work around for failed display driver was to just reinstall from CLI.

Now installing 6-0 side by side using the .DEB package (NOT .RUN!)