Jetson TK1 native install -- driver not verified

I have a new Jetson TK1 development kit.
I’ve performed the steps in:
http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#l4t-installation
(including pre and post installation).
When trying to verify the driver installation as described in
http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#verify-driver
I get the error message
cat: /proc/driver/nvidia/version: No such file or directory

I can compile but not execute the examples.
Have I left something out?
The section
http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#runfile-installation
describes a .run file. What run file is that?

>>>I can compile but not execute the examples.
Could you please provide more information of the detail errors while running CUDA samples on your Jetson TK1 platfrom?

>>>What run file is that?
In CUDA download page(i.e. CUDA 6.5 production release - https://developer.nvidia.com/cuda-downloads). It provides standalone installer(.run file) and RPM/Deb installers for Linux.

when attempting to execute (for this instance: deviceQuery) from the GUI a popup declares:
Could not display “deviceQuery”
There is no application installed for “executable” files.
Do you want to search for an application to open this file?

You are installing the wrong package. The driver for Jetson is coming with the system image.
Follow the instruction at http://elinux.org/Jetson/Installing_CUDA.

Sorry mfatica: I find no page at your URL.

So, I’ve tried running from the command line. This is what I see:

ubuntu@tegra-ubuntu:~/NVIDIA_CUDA-6.5_Samples/1_Utilities/deviceQuery$ ./deviceQuery
./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

Take the period off that URL and it will work fine.

http://elinux.org/Jetson/Installing_CUDA

Thanks. These instructions are straight-forward, and uncomplicated by host issues.
I followed some similar instructions that didn’t include the usermod part.
I had done these things except I downloaded cuda-repo-l4t-r21.2-6-5-prod_6.5-34_armhf.deb
and substituted 6.5 for 6.0 where necessary. Like I explained, I get the driver version error message.
I am not certain how to diagnose the problem further, or how to respond to it.
Did I get the right package?
Should I uninstall 6.5 and try 6.0? In which case: how do I uninstall 6.5?
I do appreciate your help.

doesn’t this show that cuda runtime and cuda driver are up to date?

ubuntu@tegra-ubuntu:/usr/lib/nvidia$ dpkg --list | grep -i ‘cuda’
ii cuda-command-line-tools-6-5 6.5-34 armhf CUDA command-line tools
ii cuda-core-6-5 6.5-34 armhf CUDA core tools
ii cuda-cublas-6-5 6.5-34 armhf CUBLAS native runtime libraries
ii cuda-cublas-dev-6-5 6.5-34 armhf CUBLAS native dev links, headers
ii cuda-cudart-6-5 6.5-34 armhf CUDA Runtime native Libraries
ii cuda-cudart-dev-6-5 6.5-34 armhf CUDA Runtime native dev links, headers
ii cuda-cufft-6-5 6.5-34 armhf CUFFT native runtime libraries
ii cuda-cufft-dev-6-5 6.5-34 armhf CUFFT native dev links, headers
ii cuda-curand-6-5 6.5-34 armhf CURAND native runtime libraries
ii cuda-curand-dev-6-5 6.5-34 armhf CURAND native dev links, headers
ii cuda-cusparse-6-5 6.5-34 armhf CUSPARSE native runtime libraries
ii cuda-cusparse-dev-6-5 6.5-34 armhf CUSPARSE native dev links, headers
ii cuda-documentation-6-5 6.5-34 armhf CUDA documentation
ii cuda-driver-dev-6-5 6.5-34 armhf CUDA Driver native dev stub library
ii cuda-license-6-5 6.5-34 armhf CUDA licenses
ii cuda-misc-headers-6-5 6.5-34 armhf CUDA misc headers
ii cuda-npp-6-5 6.5-34 armhf NPP native runtime libraries
ii cuda-npp-dev-6-5 6.5-34 armhf NPP native dev links, headers
ii cuda-repo-l4t-r21.2-6-5-prod 6.5-34 armhf CUDA repo configuration files.
ii cuda-samples-6-5 6.5-34 armhf CUDA example applications
ii cuda-toolkit-6-5 6.5-34 armhf CUDA Toolkit 6.5 meta-package

I still get the error message when I try to run deviceQuery:

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

none of that says anything about the GPU driver installed. You may still have a GPU driver installed that does not support CUDA 6.5

It’s likely that if you had followed the instructions as-is, and installed CUDA 6.0, then things would work.

To use CUDA 6.5 on Jetson you will need L4T r21.2

https://developer.nvidia.com/jetson-tk1-development-pack

Follow the install guide linked there.