deviceQuery fails: CUDA driver version is insufficient

I run a Debian Jessie on a Tegra-K1 board (Toradex Apalis-TK1), installed the CUDA toolkit 7.0 and the nvidia_drivers.tbz2 from the Jetson TK1 21.5 package.

Now I get

$ nvcc -V
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2015 NVIDIA Corporation
Built on Fri_Oct_16_15:23:46_CDT_2015
Cuda compilation tools, release 7.0, V7.0.70

$ cat /etc/ 

$ cat /etc/nv_tegra_release 
# R21 (release), REVISION: 5.0, GCID: 7273100, BOARD: ardbeg,  EABI: hard, DATE: Wed Jun  8 04:19:09 UTC 2016
50e7e42bde409d5ba0eb410d803b991cd6c4c32b */usr/lib/xorg/modules/extensions/
cc612c5afcb8a76a5b847fc500d2354582d32abb */usr/lib/xorg/modules/drivers/
e96a78d9c3947a980f065d96557f98c70500db17 */usr/lib/arm-linux-gnueabihf/tegra/
... and so on ...

I was able to build the NVIDIA_CUDA-7.0_Samples (using make SMS=53 to avoid linking problems), but

1_Utilities/deviceQuery/deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

How can I narrow the cause of the problem?


Incompatible between CUDA-toolkit and CUDA-driver cause the error.
Rel-21.5 can’t support CUDA-7. It can only support CUDA-6.5.


On the download page, I can neither find CUDA drivers for TK1 newer than 21.5 nor a toolkit older than 7.0

FYI, CUDA 32-bit stops at version 6.5 as being the most recent. To go beyond 6.5 you need a 64-bit architecture…and since TK1 is 32-bit there won’t be a newer version.

One more reason to be able to download 6.5. But from where?

These days it is expected to use JetPack…mostly access to directly download CUDA for Jetsons was removed. You can use a trick with JetPack to get the URL and then use wget to manually download, but there may be a number of dependencies making it a more difficult task (as I recall complicated dependencies may be part of the motivation to put this only in JetPack). Some people (such as myself) cannot install Ubuntu (it has installer bugs which cannot be worked around without destroying a license key and all of my current multi-boot operating systems) on the PC…if you need to know about the trick to get URLs from JetPack for manual download see:

bash ./ --noexec

Running “./Chooser” produces produces human-readable “repository.json”…URLs are in this.

Just use JetPack if you have the option.


As linuxdev said, please install CUDA-6.5 via JetPack directly.


This solved the problem. Thank you very much!