CUDA driver version is insufficient for CUDA runtime version on Jetson TK1

CUDA newbie here. I just received my Jetson TK1 and I was trying to run the examples from the NVIDIA_CUDA-6.5_Samples folder but all the samples return the same error:

1_Utilities/deviceQuery/deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

I used the filesystem provided with the board, installed the NVIDIA drivers from the NVIDIA-INSTALLER folder, performed an apt-get update, installed the CUDA-SDK 6.5 from the Jetson TK1 support page and compiled the samples with make. Further apt-get update or upgrade didn’t solve the problem. I tried “sudo apt-get install cuda-driver-dev-6-5” but it says I already have the newest drivers:

Reading package lists… Done
Building dependency tree
Reading state information… Done
cuda-driver-dev-6-5 is already the newest version.
cuda-driver-dev-6-5 set to manually installed.

Any advice?

I reply to my own question. The issue is that the board came with Linux for Tegra R19 while CUDA 6.5 works only (AFAIK) on R21. Since I don’t have a Ubuntu host computer right now, I uninstalled CUDA 6.5 and installed CUDA 6.0 instead and everything works fine. Maybe there’s a way to update the NVIDIA drivers on R19 and still use CUDA 6.5, but I don’t know how.

Hey AndreaC,

I have the same issue with my Jetson board. How did you uninstall CUDA 6.5 toolkit? I searched through /usr/local/cuda-6.5/bin and I couldn’t find any uninstall.pl file!!