CUDA 2.0, Vista x64 Builds, GX2, & Dual-display SDK apps fail to build & 2nd LCD gone!

Hi guys,

I’ve noticed two problems after installing CUDA 2.0’s Vista64 components. I’m running Vista64 and a 9800GX2.

1. Compiling CUDA Sample Apps
Compiling any sample app in the SDK reports:
cannot open input file ‘cutil32D.lib’

So I compiled cutil, and then tried a sample app compile again, now reporting:
module machine type ‘x64’ conflicts with target machine type ‘X86’

These attempts were done to the distribution as is. I did later attempt to compile after changing the machine type to MachineX64, without luck. Am I missing something related to the linker, machine type, etc? Obviously something extra needs to be done on top of the original distribution.

2. Dual-display Detection
The second LCD fails to be detected after installing the driver provided in the CUDA 2.0 post. Is this happening to anyone else, or have suggestions? Displays worked fine with the 174.74 driver. This is especially important, since the key notes in the CUDA 2.0 post say using multi-GPU requires an extended desktop per additional GPU.

And yes I realize this is beta, but I figure someone may still have solutions. Thanks for reading :)

  • Korax

You should probably only try building for the x64 target on Vista64. Make sure you select that in Visual Studio

I’ll try again with the GX2. You will need to disable SLI and then extend the desktop onto it for the multiGPU cuda samples to work.

ok thanks, I think you have found a bug with the gx2 not working with dual displays with this driver for vista64. I see the same problem. Thanks

Glad to help!

I should also add that this display problem doesn’t occur in WinXP 32, for the record.

But about the build problem, yes you’re right. I had to change three things in an app project settings:

Win32 —> x64 target
MachineX86 ----> MachineX64
Linker dependencies: cutil32D.lib —> cutil64D.lib

It would be nice if the 64-bit distribution had these project settings already configured though. I foresee several folks running into this obstacle in the future.

Hi

I solved the same problem by opening VS2010 in adminstrator permission.