CUDA 2.0 beta on Vista 32 error


I am getting the required openGL extensions are missing error when trying any OpenGL-enabled demo from the SDK. the dll’s are in the same directory as the executables (c:\cuda\bin\win32\release). I tried copying them to c:\windows\system32, but that did not help a bit.

GPU on my notebook is 8600M GT 512 MB

Anybody know what I need to do to make them work?

I also have almost the same problem. I installed the nVIDIA driver 174.55 to my laptop with Vista 32-bit as OS and GF8400MG as the GPU.

When I run my sample program written in OpenGL, on the program is usually shown the OpenGL version and the renderer. Previously, it’s shown GeForce 8400M G with the OpenGL version is 2.1. But now, after installing the driver, it becomes Window GDI Generic. Also, my another program which uses Cg can’t work and get the “invalid profile” message.

I wonder if this also happens to XP and previous version of CUDA.

NVIDIA has been able to reproduce this on several laptops, so it will probably be fixed in the next driver release.

I’m having the same problem with my 8600GT on a desktop PC (Vista, CUDA 2.0 Beta).

I’ve found a fix for the opengl problem on Vista (32 and 64) in this initial beta 2.0 release. It is strange but it works once I noticed this was the only difference between my systems that were working and those that weren’t

You need to disable User Access Control (UAC)
Go into the vista control panel->User Accounts->Turn User Account Control on or off

Uncheck the box “Use User Account Control (UAC) to help protect your computer”

It’s strange that the protection shows up with failing opengl messages. I figure there’s something we need to do in how the display driver installs to properly fix this.

And for those who are not finding a CUDA device, check in the \Windows\system32 to see if the file nvcuda.dll exists.

If it’s not there, the display driver didn’t copy it in correctly. This is due to some of the notebook INF files I had included somehow dropping this. I’ve attached an example you can use. This works for the Dell notebooks such as the D830 that’s been reported.

Save the attached file as nvdm.inf into the \NVIDIA\WinVista64\174.55 directory and run setup.exe from that directory. You can see the 2 references in the attached INF file to nvcuda.dll. I’ll get these correctly updated and reposted to the other INFs but this example will work for anyone who wants to do this on their own.

To get OpenGL and CUDA using 174.55 beta driver for Vista, you have to run with Administrator privileges and you have to turn off UAC.

Please fix these issues for the next beta or RC release.


I used to have the same issue on my laptop. All I had to do to get OpenGL working is running the app in Administrator mode. It seems disabling UAC is not a requirement.


The user under which I logon has administrator priviliges, but still it did not work.
Logging in as administrator is not something you want to be doing normally.

Vista “re-used” some Unix concepts when it comes to Administrator rights.
Having Administrator privileges doesn’t give you Administrator rights by default. You have to explicitly ask for them. You can do this by right clicking the app icon and using “Run as Administrator” (or run your dev environment like this).

Compare this feature to sudo in *nix.



I have almost the same problem. I tried to install the 174.55 with the inf from above (changed the nvdm.inf to nvdisp.inf, cause nvdm didn’t exist), but it didn’t worked out.
so i installed the 174.74 instead. this version doesn’t seemed to have CUDA support. I then just copied the nvcuda.dll from 175.55 into Windows\system32. with that the deviceQuery-example displays my card as cuda capable, but the other samples don’t work. Is there a solution? maybe a new driver or a modded inf for the 174.55 that works?? I’m using Vista 32-bit and have a 9500m GS. I definitely need some help with this :wacko: .


Hi Robert,
It doesn’t appear we got the new 9500m device id into this beta - it was too new to make this cut. Will have to wait until we add that one. I looked through the Acer and Asus inf files and didn’t see them in there. I think you’ll just have to wait. Please let me know the exact model notebook you are using? Also please post the exact device id

Get this from the Device Manager->Display Adapers->
go to Details tab and pull down on the property->Hardware Ids. Post the complete top line


I have an Asus X55SV-AP119C. The device ID is:


Is there a “quick hack” to get CUDA running. I mean after copying the nvcuda.dll into the system32 directory, CUDA recognized my card. maybe there are some more files I just have to copy or so.

Greets Robert

Thanks Robert,
please try this:
Get a clean copy of the beta 174.55 vista driver expanded by running the installer . It will populate \NVIDIA\WinVista\174.55

Save the new file nvam.inf.txt [attachment=6295:attachment]I’ve posted here into that directory as nvam.inf (replacing the one that will be extracted by the installer)

Then run the setup.exe.

This should add support for your Asus model with 9500m

Please let me know if that works or if you have questions.

thanks for helping with this beta!

Thanks a lot, it works. The sample files execute well. Though everything seems to work
fine, I got some errors at the end of the driver installation. Something with the nvcp.dll. I tried to make some screeshots of this, but I couldn’t reproduce the error with a second installation, sorry. Thanks again for the good support. If I notice something that looks not alright, I’ll post it.


Read the announcement:

9800 GTX support didn’t make it into the beta.

Hi all,

for some reasons I had to switch to Win XP, now I’m facing the same problem again, that my 9500M GS isn’t recognized by the driver setup. I’ve searched for a modded inf,
but unfortunately I’ve found none. Could anyone provide a solution?

Thanks in advance

I recently bought a Gateway P-6860FX notebook with a 8800M GTS. I am trying to run CUDA 2.0. I have driver version installed, and CUDA is not recognizing the GPU. Running the installs does not result in the cuda dll being installed in system/win32. The Hardware ID is PCI\VEN_10DE&DEV_0609&SUBSYS_0690107B&REV_A2.

Can you please make some suggestions?

Also, how can I use Visual Studio 2008 with CUDA?



I just bought a laptop with 9500M Gs on it. (Hardware ID PCI\VEN_10DE&DEV_0405&SUBSYS_16341043&REV_A1).

Is there anyway to get CUDA working with this?

Thanks in advance,


I thought that CUDA was only for 8800 and 9800?

No. CUDA can be used on any NVIDIA GPU since the 8800.