Vista x64 - nvcuda.dll not found Cuda not working on Vista 64

Hi, i have an ASUS g50vt notebook with a GeForce 9800M GS and i decided to install some development tools, including CUDA, all tools works fine (including PhysX Hardware simulations) except CUDA, when i run the video decoder example from the SDK i get a “nvcuda.dll not found” error, some other examples run in device emulation mode.

I am using Windows Vista Home Premium with driver 179.14, and nvcuda.dll is located in C:\Windows\SysWOW64.

i’ve already tried to uninstall driver and install it again, the same with CUDA SDK, but with no success.

What is the problem? How to solve it?



The info report:

Processor: Intel® Core™2 Duo CPU P8400 @ 2.26GHz (2261 MHz)
Operating System: Windows Vista ™ Home Premium, 64-bit (Service Pack 1)
DirectX version: 10.0
GPU processor: GeForce 9800M GT (i don’t know why it says GT, the notebook specs says GS)
Driver version: 179.14
Stream processors: 64
Core clock: 530 MHz
Shader clock: 1325 MHz
Memory clock: 799 MHz (1598 MHz data rate)
Memory interface: 256-bit
Total available graphics memory: 2303 MB
Dedicated video memory: 512 MB
System video memory: 0 MB
Shared system memory: 1791 MB
Video BIOS version: 62.94.3C.00.01
IRQ: 16
Bus: PCI Express x1


nvCplUIR.dll NVIDIA Control Panel
nvCpl.cpl NVIDIA Control Panel Applet
nvExpBar.dll 1.5.740.18 NVIDIA Control Panel
nvCplUI.exe NVIDIA Control Panel
nvViTvSR.dll NVIDIA Video and TV Server
nvViTvS.dll NVIDIA Video and TV Server
nvDispSR.dll NVIDIA Display Server
NVMCTRAY.DLL NVIDIA Media Center Library
nvDispS.dll NVIDIA Display Server
NVCPL.DLL NVIDIA Compatible Windows Vista Display driver, Version 179.14
nvGameSR.dll NVIDIA 3D Settings Server
nvGameS.dll NVIDIA 3D Settings Server

Hi, a little edit: today i copied the nvcuda.dll from SysWOW64 to C:\CUDA\bin, now i have the following error: the application failed to initialize properly(0xc0000007b).


That’s a pretty weird driver version. I’d use 180.60, probably, and modify the INF so it supports that chip officially.

Thanks, i will try this version, but then i need to install the Cuda 2.1 beta, right? As for the driver, where can i find the modified INF file?

Did this ends the success ?

Driver updated to 180.70 with modified inf, CUDA 2.1 tookit installed and All examples running perfectly! Thanks everyone!

thank you ?
what do you do on CUDA ?

Where is that ? I think about 180.70 Inf ?

Have you driver for Quadro FX 4600 on Vista 64 bit as soon as 180.70 inf in order to CUDA 2.1 works ? is 180.70 inf works on FX 4600 in CUDA 2.1 environment ?