There is no device supporting cuda using 8600M GT on a laptop

I’ve installed forceware drivers 169.21 using laptopvideo2go.com’s hacked .inf file.
CUDA 1.1 SDK and toolkit is installed, but the sample projects still give me a “There is no device supporting cuda” error message.

I’ve reinstalled drivers and sdk several times now to no avail.

Any help is appreciated.

Hi

I have the same error…but first, i cant install the cuda driver; it says hardware necessary not found (or something like that).

Well, that is why you have to use laptopvideo2.go’s hacked .INF file, and overwrite the existing .inf file in the unpacked driver data with the one you download off that page.

great, I have done it and now I can run all the examples.
I dont get that error anymore.

thanks

=/ Why isn’t it working here then =(
I did the exact same procedure on my desktop computer that has an 8800ULTRA card, and it worked perfectly.

No one with any experiences with the 8600M GT?

I have a 8600M GT

did u also install sdk platform, i did that before…

Nailer
What OS are you running?
It’s the first time such problem occurs. My Acer 5920G with 8600M GT works just fine.

  1. Check that you’ve actually installed driver, rebooted, etc. (I’m sure you’ve done it correctly).
  2. Have you installed 1.1 toolkit over 1.0 or performed a clean install? When upgrading to 1.1 it’s requred to uninstall 1.0 first. Try uninstalling 1.1 Toolkit and SDK, rebooting and installing them again.

Let us know if this helps.

My guess is you’re not installing a driver that has the nvcuda.dll

This “hacked” inf file people are talking about seems to have the right devices and references to nvcuda.dll. I’ve found one here
http://www.laptopvideo2go.com/infs/165seri…21/nv4_disp.inf

Make sure you’re only installing a driver that actually places nvcuda.dll into your system32 windows directory
such as the released GeForce driver
http://www.nvidia.com/object/winxp_169.21_whql.html
, or if you’re really brave try the newest beta driver
http://www.nvidia.com/object/winxp_169.28.html

It will give you the standard message during installation on a notebook
“The NVIDIA Setup program could not locate any drivers that are compatible with your current hardware.”

The driver will have still left the extracted installation files on your disk.
(usually in \NVIDIA\Win2*\169.2*…)
Go into that directory and replace the inf file that was extracted with the nv4_disp.inf from the link above and run setup.exe in that same directory.

I’ve just done this on my 8600M GT. The driver installation complained about a few dll’s but just hit cancel and tell it to continue. works fine. I think the missing dll’s are simply because the hacked inf file above references some files that don’t actually exist.

And, as mentioned, then you need the CUDA v1.1 toolkit and sdk.

It’s important to remember that this is going with an unsupported driver on your notebook - one not approved by your notebook vendor. Even if you use the Released 169.21, that’s not for notebooks. I’ve seen notebook vendors that are in the process of updating to newer drivers that do include CUDA, but it takes a while (send them a note requesting it ;) . So if you use the unsupported driver, you may not get access to certain features or special buttons on your notebook. But for now it’s the way to get CUDA and to get on a newer driver.

Please post here if this works for anyone or if anyone has problems with this.
If it works, I’ll move this post up so hopefully folks can find it faster.
Thanks!

No matter what I do the nvcuda.dll refuses to be installed.
Now I’ve tried both the beta and the other driver.

However, when I copied nvcuda.dll from one of my friends’ computer into the System32 folder everything worked like a charm.

That’s intersting. Don’t know if that’s some kind of priv problem.

One note: if you’re trying to install the 169.21 GeForce driver, you would find the nvcuda.dll that you need in the directory where the driver installation files are extracted. Still nice of your friend to provide one.