GF driver for cuda in vista x64 but w/o opengl

I have gf 174.55 for cuda but this driver hasn’t opengl for games and for applications! :thumbsdown: :/
which is the other version or 174.xx driver w/ opengl for cuda???

I have 174.55 and feel ogl applications in nv ogl sdk all work right and have same fps & effects with them under XP. Is your applications problem?
but… i feel the 174.55 not works right for cuda~~ :( i got the no device error

I worked fine in samples cuda and games directx. but I didn’t work in games opengl (eg: doom3 - errors and not run) and in apps (eg: celestia - slow)

It would be very helpful to know if Vista64 is working or failing for anyone trying this.

Please report on this thread if you’re using a desktop machine and which GPU card. Or if a notebook which exact notebook model with which GPU.

Let me know which Vista version you have and if you have SP1 32-bit or 64-bit.

If you are having OpenGL problems, could you please try a few of the example apps in the Cg toolkit

http://developer.download.nvidia.com/cg/Cg…n2008_Setup.exe

This would be easier than trying various games for now just as a reference point.

Also please note that 174.55 is only a test driver for this beta test period. We will not move to a production version of 174.55. When we have the release version of CUDA 2.0, it will be on a different and newer driver version. Then going forward all newer standard drivers for Vista will have CUDA support.

Thanks very much everyone for helping with this beta period. Really appreciate it!

I have tried on two machines with Vista64 SP1:

A Dell D830 laptop with a Quadro NVS 140M: Driver installs, works for DirectX, but fails for all CUDA and OpenGL.

A desktop with an 8800 GTS 512: Driver installs, works for DriectX, CUDA (although performance is much lower than the same machine running linux). Doesn’t work for OpenGL (and thus and CUDA sample that tries to use CUDA).

In the cases where OpenGL isn’t working:

glGetString(GL_RENDERER) = “GDI Generic” (i.e. no NVIDIA ICD)

If there are any other things you need to know, I can post them also.

Please try installing the Cg toolkit and let me know if that helps with the CUDA samples

I’ll look for some other suggestions.

I’ve got a few machines including my Sager notebook with dual 8800mGTX running Vista64 and all OpenGL is working.

you have read my specs of pc in my profile.

I don’t want update sp1 for vista because this update will may be slower for games/apps.

I tried reinstall new cg but I still don’t work. before I had 174.74beta w/o cuda for work opengl games.

PS: sorry for bad english. ;)

Hi nuninho1980.

Sorry I don’t see which Graphic card you are using?

thanks,
-Dave

Okay, my machine does not work with the OpenGl apps.

MSI GX 700 notebook
Vista Home Premium 32 bit
8600M GT 512 Mb

Both CUDA and Cg are not working with OpenGl.

I have and I love 8800gts 640. :)

I worked all samples cuda.

The OpenGL samples in the Cg Toolkit don’t run. If I revert back to an earlier driver, OpenGL works again.

I can try swapping the harddrive and doing a fresh install of Windows on my laptop to make sure there isn’t anything funky, as well as test pre SP1. If I do that I can also test Vista32 and XP64.

The only other thing that my two machines have in common is 4GB of RAM.

OK I see the problem. As I suspected there are some problems with all the INFs.
First of all many of the notebook INFs somehow had their reference to install nvcudal.dll missing. So that’s why deviceQuery on some notebooks isn’t even working.

I suspect it’s a similar problem for opengl issues. I’ve just installed a clean Vista64 onto a Dell D830. Sure enough on this system sure enough no CUDA device was found. Once I added the 2 nvcuda.dll references to nvdm.inf file, now CUDA works on it.

I’ll most likely just post some updated INFs in the short term.

  1. I installed the 174.55 driver on a clean vista x64 ultimate;
  2. Samples in NV OpenGL SDK work right, but CUDA couldnot work(no device error);
  3. I installed the same 174.55 driver again on my vista x64;
  4. CUDA works right, but samples in NV OpenGL SDK always “stopped working” at the startup;
    Magic~~ :magic: