CUDA not detected with 8800GT under vista32 no device supporting cuda error on vista

Hi All,

I just completed a new machine build and wanted to hit the ground running this weekend but I’m stuck on step 1 (maybe 1.5).

I have installed the latest drivers (177.35) along with the 2.0 toolkit and sdk but I was seem to get any of the examples to run via the sdk-browser. I then fired up a shell and ran ‘deviceQuery.exe’ which returned the following…

C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\bin\win32\Release>deviceQuery.exe

There is no device supporting CUDA


Press ENTER to exit...

C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\bin\win32\Release>

Any ideas? I already searched the forum but found nothing. I also tried an older driver (174_55) as well but still no luck.



Did you use the drivers with the modded .inf? No cards under the 9 series is offcially supported, I got my G92 GTS’s working by using the 177.39 Vista 64bit driver and then I found a modded .inf that allowed me to install the driver.

Then you have to install the latest PhysX driver which I don’t know off hand, but I could get it for you. Did you get the drivers installed with the modded .inf? If so, did you install the PhysX driver?

Let us know, and maybe we can get you up and running.


Not true; that was a bug in the released version that we fixed via an updated package. The current 177.35 on CUDA Zone supports all non-mobile CUDA capable cards. (Mobile users still need to modify the INF themselves…)

Anyone out there with another suggestion? I’m not sure about the above responses, all I know for sure is that 177.35 is the highest driver I can find on CudaZone, assuming that is my problem.


Are you using two graphics cards, with one dedicated to CUDA? According to the Release Notes for CUDA 2.0, under Vista, the Windows desktop must be extended onto the GPU in order to run CUDA.

This was the first thread I came across in my search for answers as to why the GPU has to be attached as a display in the first place. Under Windows XP, the 5 second limitation is avoided by using an additional video card. Why doesn’t this apply under Vista and will there be a workaround?