CUDA 6.5 (32-bits) : get samples when gcc version not supported

Hi all,

I installed CUDA 6.5 because my computer has a 32-bits processor.

Configuration :
Xubuntu 14.04 LTS 32-bits
CUDA 6.5
nVIDIA TESLA C2075
gcc 4.8.4

During the installation I have to use -override because this gcc version was not supported.
In ended with :

Driver: Installed
Toolkit: Installed in /usr/local/cuda-6.5
Samples: Not Supported

Is there a way to get the samples anyhow ?

take the CUDA 6.5 linux runfile installer and extract the indvidual installers (driver, cuda toolkit, samples). I don’t remember the exact commands to do this but if you run:

sudo sh cuda_6.5_installer.run --help

It will give you installer command line help (replace cuda_6.5_installer.run with the actual name of the runfile installer you are using).

With that command line help you can extract the 3 individual installers. Then either run the samples installer directly, or use the same method to get command line help for the samples installer to figure out the switches to do a force install.

Thanks txbob, I tried the following command :

$ sudo sh cuda_6.5.14_linux_32.run -silent -samples

But the output was not very conclusive :

===========
= Summary =
===========

Driver:   Not Selected
Toolkit:  Not Selected
Samples:  Not Supported


***WARNING: Incomplete installation! This installation did not install the CUDA Driver. A driver of version at least 340.00 is required for CUDA 6.5 functionality to work.
To install the driver using this installer, run the following command, replacing <CudaInstaller> with the name of this run file:
    sudo <CudaInstaller>.run -silent -driver

I checked the output of the installation, the driver is said to have been installed properly :

===========
= Summary =
===========

Driver:   Installed
Toolkit:  Installed in /usr/local/cuda-6.5
Samples:  Not Supported

I still tried to install the driver as it told me, but of course it did not work because it is already installed…

ERROR: An NVIDIA kernel module 'nvidia' appears to already be loaded in your kernel.

I don’t know if the error might come that I first tried to install cuda 7.0, before realising it was for 64-bits so I uninstalled it and installed 6.5 (with several reboot to avoid the ‘NVIDIA kernel module loaded’ error), or something else…

Did you extract the 3 individual installers?

Did you run this command as I suggested:

sudo sh cuda_6.5.14_linux_32.run --help

Please do that, then look for the word extract in the help output.

Use the extract command to extract the individual installers.

Then run the samples installer by itself. This installer has options as well, you can see those with --help

I did not do it, now I extracted the individual installer but the output gave me only 2 installers eventhough it said it will give 3…

$ sudo sh cuda_6.5.14_linux_32.run -extract=/MYPATH
Logging to /tmp/cuda_install_2554.log
Extracting individual Driver, Toolkit and Samples installers to /home/leila/Downloads ...
$ ll
76788277 Aug 19 14:10 cuda_6.5.14_linux_32.run
38016053 Aug 20 16:30 cuda-linux-rel-6.5.14-18745345.run*
38639822 Aug 20 16:30 NVIDIA-Linux-x86-340.29.run*

OK that is probably correct. I don’t use the 32-bit packages much anymore. Referring to the getting started guide for linux on CUDA 6.5:

http://developer.download.nvidia.com/compute/cuda/6_5/rel/docs/CUDA_Getting_Started_Linux.pdf

32-bit support has a variety of limitations, many of which would impact which samples would be usable. Therefore I am guessing that the 32-bit package doesn’t include the samples intentionally.

You could try grabbing the 64-bit runfile installer, and extracting the samples installer, and try installing that. I don’t know what would happen, so I won’t be able to help much.

It’s probably easier if you can switch to a 64-bit machine.

The 64-bits examples don’t work. While using make :

nvcc fatal   : 'i686': expected a number

Moving to a 64-bits machine. Thanks for the quick support.