CUDA [7.5] driver Version is insufficient for CUDA runtime version

Your original posting indicates use of a package manager install.

Now you’re suggesting you also did runfile install. Runfile install and package manager install are incompatible, and if you attempt to do both on the same machine without taking special cleaning steps, you will have trouble. That is why I suggested starting over with a clean install. If you don’t wish to do that, I don’t think you’re going to have good luck if your machine configuratino is corrupted this way.

I don’t see debian jessie listed as an officially supported CUDA OS. Perhaps you might want to switch to one of the officially supported distros.