Cuda : Depends: cuda-11-4 (>= 11.4.14) but it is not going to be installed

I installed the nvcr.io/nvidia/l4t-tensorrt:r8.4.0-runtime docker image on Orin, but when I try apt install cuda I get the below error.

Note that this was working previously (I’ve run this docker build script from scratch several times without issues in the past), so I guess some update in the apt repos changed. Any idea how to work around?

$ sudo apt install cuda
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cuda : Depends: cuda-11-4 (>= 11.4.14) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hi,

Is this issue fixed after using nvcr.io/nvidia/l4t-tensorrt:r8.4.1-runtime instead?
Thanks.

Yes! However, with 8.4.1 I run into a different issue: Undefined reference to `nvdla::IProfile::setUseSoftMaxOptz

Regardless of this, why did it break suddenly? Isn’t part of the point of using docker images to allow for some sort of consistency/stability that is independent of the release of new versions of things?

Any workaround to this error?

Hi,

Let focus on the nvdla::IProfile::setUseSoftMaxOptz issue on the topic 228867
Thanks.