Run cuda failure inside docker on orin

hello,when i run cuda inside docker on orin, ir ocurred error:
CUDA driver version is insufficient for CUDA runtime version inside docker,
but i can run cuda outside docker.And i check the cuda library linked to the exec is the same.

the docker’s base image is :
FROM nvidia/cuda:11.2.1-cudnn8-devel-ubuntu20.04
i have added option --gpus all when exec docker run cmd;
I solved problem by changing base image to and checked Dockerfile from nvidia / container-images / l4t-base · GitLab

but i still have no idea about why the error ocurred, what is difference of l4t-base:r34.1.1 images from nvidia/cuda:11.2.1-cudnn8-devel-ubuntu20.04 images.

If you know,please tell me.
thanks a lot.


You will need to use the container that supports Jetson (with l4t) to use GPU.


l4t is the jetpack kernel.if only l4t container can access l4t driver?

Hi @deweichen, yes, you need to use one of these containers that are built for Jetson/JetPack instead:

1 Like

ok,i got it.
thanks a lot.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.