Running Docker with CUDA >=11.8

I am trying to run docker container with Cuda 11.8 on L4T 35.4 however following error pops up:

docker: Error response from daemon: failed to create task for container: failed to create shim task: OCI runtime create failed: failed to create NVIDIA Container Runtime: failed to construct OCI spec modifier: requirements not met: unsatisfied condition: cuda>=11.8 (cuda=11.4): unknown.

Does it mean only cuda 11.4 docker image is allowed to run on l4T 35.4?

I also tried installing Cuda 11.8, still doesn’t work.


Which container are you trying to use?
It looks like the container doesn’t support Jetson (without the l4t flag).

CUDA 11.8 is available on the website.
Do you install it with the below link?


Hi @AastaLLL , thank you for quick reply.

I am trying to use docker image nvidia/cuda:11.8.0-devel-ubuntu20.04.

And yes, I installed cuda 11.8 with the link above on the Orin Nano, since I thought the error means the host required to have 11.8 or above to support running cuda 11.8 in container.


The container you used is for the dGPU.

Do you encounter any errors when using the CUDA 11.8 outside the container?
You will need to export the compat folder to solve the compatibility issue.

$ LD_LIBRARY_PATH=/usr/local/cuda-11.8/compat


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.