CUDA device emulation Problem regarding device emulation


I tried to compile some of the examples in emulation ‘mode’ (make emu=1), but I’m not able to run any of the compiled examples (matrixmul or simpleCUBLAS). The program aborts immediately with the following error:

NVIDIA: could not open the device file /dev/nvidiactl (No such file or directory).

Any help would be appreciated

Did you start X with the nvidia X driver before attempting to run the program?
Which Linux distribution are you running?

No, I haven’t, since I’m trying to run CUDA applications on a PC without a recent Nvidia graphics card (It’s a Geforce 4 something). Why would I have to run X to test any CUDA application? The Manual/Reference is not very clear on emulation.
I’m running Debian testing (etch).

Thanks for the Help.

All /dev/nvidia* files are created when X is started with the NVIDIA X driver.

OK, thanks. Problem solved itself, the Computer with the 8800GTX came this morning.

Thanks anyway!

I’m very interested in this problem, because I will be doing a great deal of debugging on a non-NVIDIA machine. Device emulation should not require opening /dev/nvidiactl.

Any ideas on getting this working in emulation mode?

I’m also interested in this problem. I don’t have an 8000 series card and I’m getting the

NVIDIA: could not open the device file /dev/nvidiactl (No such file or directory).

error. I shouldn’t need that for emulation mode, should I?

I’m compiling with

make emu=1 dbg=1