installation pb: emulation mode

i do not have nvidia graphic card, and i tried to install cuda in emulation mode. i tried to install de devdriver but the process fails 'cause i dont have de nvidia graphic card. so i’continue the installation just with cudatoolkit and gpucomputingsdk. the probleme is when i compile sdk packages with make emu=1, the compilation failed 'cause of pb link lcuda missing.


make[1]: Entering directory /home/taikovic/NVIDIA_GPU_Computing_SDK/C/src/threadMigration' threadMigration.cpp: In function ‘bool findModulePath(const char*, std::string&, char**, std::string&)’: threadMigration.cpp:100: warning: unused variable ‘fp’ threadMigration.cpp:115: warning: ignoring return value of ‘size_t fread(void*, size_t, size_t, FILE*)’, declared with attribute warn_unused_result /usr/bin/ld: cannot find -lcuda collect2: ld returned 1 exit status make[1]: *** [../../bin/linux/release/threadMigration] Error 1 make[1]: Leaving directory /home/taikovic/NVIDIA_GPU_Computing_SDK/C/src/threadMigration’
make: *** [src/threadMigration/Makefile.ph_build] Error 2


configuration software:
ubuntu9.04 linux-32
i dont have the LD_LIBRARY_PATH VARIABLE. so i replace this step by :
including /usr/local/cuda/lib in /etc/ as root but still without succus in compiling.
i did configure ma PATH variable too.$PATH=$PATH:/usr/local/cuda/bin

My question:
for those who have to install cuda in emulation mode, do we need to install devdriver?
if not why have i this kind of probleme.

thanks a lot.

Not all of the SDK examples can be built and run in emulation mode. The threadMigration is one of them because it requires the driver API, which is not supported in emulation mode. You will still be able to compile many (but not all) of the other examples.


So the solution must be removing threadmigration from SDK examples and recompile the project.