Cuda Driver/Runtime insufficient Versions

For the past couple of weeks I have been trying to install the cuda toolkit, but have had little success.

My Computer is a MacBook Pro mid 2010 using a NVIDIA GeForce 320M.

The GeForce 320M is not listed as compatible at https://developer.nvidia.com/cuda-gpus , but I have found some success stories for installations on this machine such as:
http://www.larry.sk/lab.php?lab=1

So, I tried installing the toolkit. Compilation worked properly on test programs, but spat out sporadic, nonsensical outputs. Upon further inspection, errors were being thrown on every cpu-related operation: “CUDA driver version is insufficient for CUDA runtime version”

I then tried installing older versions and combinations of cuda toolkits/drivers to no success. I have even gone as far as to downgrade clang by installing older versions of Xcode command-line tools.

So, is there any hope for running/building CUDA programs on my machine? Any advice would be useful, my project is on a tight timeline. Thank you very much :)

Probably best to switch to a different machine.

That GPU is not supported by any CUDA toolkits later than 6.5. So for best results you would want to:

  • revert the OS on your macbook to an OS X version that was current in that timeframe. We are talking around 2012-2013 Also applies to Xcode/clang
  • install a GPU driver and CUDA driver for your macbook from that timeframe, that was designed to work with that OS
  • install a CUDA version that was no later than 6.5

Attempting to do this on anything resembling a recent version of OS X is going to be fraught with difficulty. And I wouldn’t be able to give you a step-by-step recipe for how to do what I suggested above.

That GPU is obsolete. It is not supported by NVIDIA anymore.

Thank you for the quick response, much appreciated