CUDA driver version is insufficient for CUDA runtime version

Hi

I installed CUDA 9.1 with nvidia-384 driver, and can only compile cuda code but not execute them: “CUDA driver version is insufficient for CUDA runtime version”.

I searched and tried the methods provided in the other posts like reinstall the driver bit dosen’t work.

The only thing went wrong during the installation was that CUDA 9.1 runfile keep reporting “An incomplete installation of libglvnd was found” so I just install the driver-384 separately from cuda-toolkit. Would it be the problem here? Thank you.

The software and hardware information:

$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  384.111  Tue Dec 19 23:51:45 PST 2017
GCC version:  gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.5) 

$ nvcc -V
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2017 NVIDIA Corporation
Built on Fri_Nov__3_21:07:56_CDT_2017
Cuda compilation tools, release 9.1, V9.1.85

$ lspci
02:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 3GB] (rev a1)
02:00.1 Audio device: NVIDIA Corporation GP106 High Definition Audio Controller (rev a1)

yes, that’s the problem.

CUDA 9.1 requires a 387.xx or higher driver.

follow the instructions in the linux install guide.

Thank you for the reply.

Another reason I didn’t use 387 driver was it will cause login loop, and I most solutions suggest using autoinstall which will install 384 driver…

I tried the runfile and deb package to install them, but both lead to the login loop.
Do you know any solution to can solve the loop without downgrading to 384?
Still looking for solution…

Try using the network deb installer, it should pull in the 390.12 driver.

If you have to login loop problem, this might work out for you (worked for me so far, no matter what version) : https://kislayabhi.github.io/Installing_CUDA_with_Ubuntu/.
I also tried to get it running with 384, but haven’t tried installing a higher version with the article above.