Getting the error: 'cuda driver version is insufficient' despite installing 387 driver

OS: Linux 4.13.0-25-generic
Distro: Ubuntu 17.04
Machine: Inspiron 15 7000
GPU: Nvidia GeForce GTX 1060 Mo
CUDA: 9.1

I carefully followed the instructions to install CUDA 9.1 on Linux

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/

including ensuring the PATH and LD_LIBRARY_PATH variables are set correctly. I can also compile the examples in ~/NVIDIA_CUDA-9.1_Samples and nvcc -V returns version V8.0.61.

When I get to the step deviceQuery

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/#running-binaries

I get the error message

‘cuda driver version is insufficient’

If I check nvidia-smi
, I get:

±-------------------------------------------------------

NVDIA-SMI 387.4

In other questions of the forum, the answer to this problem was the upgrade of the driver to a r387 version. But I already have it.
After many attempts, no solution seems to work.

Any suggestion?

If you installed CUDA 9.1 and nvcc -V returns 8.0.61 then your CUDA install is broken. You didn’t do it correctly or you missed a step.

And this:

±-------------------------------------------------------

NVDIA-SMI 387.4

doesn’t look like valid nvidia-smi output. Not sure what driver you have, but you may have the wrong driver.

Thanks

I purged the old installation and I installed CUDA all over again. I carefully checked that not a single step was missed.

Now, nvcc -V returns version 9.1, V9.1.85.

If I use nvidia-smi, I still get NVIDIA-SMI 387.34 Driver Version: 387.34 (the computer where I write this reply and the previous query is a different one from the one where I run Ubuntu, so I am only copying part of the output; I thought that showing NVIDIA-SMI was enough to make the point that the installed driver seems to be 387.34).

If I use cat /proc/driver/nvidia/version I get

NVRM version: NVIDIA UNIX x86_64 Kernel Module 387.34 (plus info on date and GCC version 6.3)

However, after I type deviceQuery, I still get

->CUDA driver version is insufficient for CUDA runtime version
Result=FAIL

Any suggestion?

Thanks

is this on a laptop?

what is the result of:

dmesg |grep NVRM

?

Thanks for the reply.

Yes, a laptop: Dell Inspiron 15 7000.

dmesg |grep NVRM

results in:

[ 2.292749] NVRM: loading NVIDIA x86_64 Kernel Module 387.34 Tue Nov 21 03:09:00 PST 2017 (using threaded interrupts)

Thanks

My guess is that everything appears to be working correctly, except that your laptop is not enabling the discrete GPU because it is an optimus laptop. You may want to investigate any BIOS options to force the GTX1060 to be always on, or else investigate nvidia prime or bumblebee, to control enablement of the graphics.

https://askubuntu.com/questions/877651/nvidia-prime-or-optimus

if you installed via the package manager method (apt-get) it may be that you have nvidia-prime installed already. You could try the prime-select command to turn on the NVIDIA graphics.

sudo prime-select nvidia

prime-select query

You can also access nvidia prime from the nvidia-settings control panel, if you are running a GUI/desktop

Dear txbob
I have got similar errors. My driver version is 384.111, and I installed CUDA9.1.85_387.26. Then, when doing ./deviceQuery, I also get an error:
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

My computer is DELL PRECISION T7600.

I think the error may be that the driver 384.111 is too low for CUDA9.1.85_387.26. However, what can I do now?

Yes, CUDA 9.1 requires a 387.xx or higher driver.

To install CUDA, get your installers from: http://www.nvidia.com/getcuda

and follow the instructions in the linux install guide:

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

  1. I purged all the CUDA installations, including the examples and compilation.

  2. Installed CUDA from scratch following instructions, but adding the Daemon performance and export path instructions to my .bash_profile.

  3. Shut down and restart.

  4. Recompiled all the examples being sure I used nvcc 9.1.

That did the trick and now it works. For some reason, there was a nvcc 8.0 floating around in my laptop. Odd, since it is a brand new one.

Thanks for your help.