CUDA grid launch failure while debugging Nsight, Visual Studio edition (dual-GPU)

I always get a CUDA grid launch failure while debugging with the CUDA Nsight Legacy debugger.
Normal (c++ part) debugging or running the program without kernel (NSight) debugging does work however.

I’m using a laptop with the following configuration
Windows 10 Pro 1709
Visual Studio 2017 (NSight edition)
CUDA toolkit: 10.0
NSight 6.0
The laptop has two gpu’s. A Intel UHD 630 and a NVidia GTX 1050

Nothing has resolved my issue so far. Could anybody help? If I need to provide additional information that could help you, please ask.

Error message:

CUDA context created : 206ddb35f60
CUDA module loaded:   206ed14f7a0 kernel.cu
CUDA grid launch failed: CUcontext: 2228512579424 CUmodule: 2228770633632 Function: _Z17d_attention_modelPfPjPKfS2_S2_S2_S2_PKtS4_PKbtjtttffff

NVidia-SMI information

Tue Dec 11 10:42:30 2018
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 417.01       Driver Version: 417.01       CUDA Version: 10.0     |
|-------------------------------+----------------------+----------------------+
| GPU  Name            TCC/WDDM | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1050   WDDM  | 00000000:01:00.0 Off |                  N/A |
| N/A   37C    P8    N/A /  N/A |     75MiB /  4096MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

Does somebody know how you activate the Windows Hybrid Graphics driver?

My visual studio Nsight concludes its disabled.

Hello,
Did you solve the CUDA grid launch failure while trying to debug with Nsight?
I have a very similar setup compared to what you described above.
Win 10, Enterprise 2016 LTSB
VS 2017 Pro. ver. 15.6.4
CUDA 10.0
Nsight 6.0
Intel® HD Graphics 530 & NVIDIA Quadro M2000M
Driver - R441.28 (r441_20-3) / 25.20.100.6472 (12-10-2018)

I cannot set a breakpoints in my CUDA kernels and debug them using the CUDA debugging legacy capability. I’m always getting the CUDA grid launch failure.

Previously I had the VS2015, CUDA 9.0, older version of display driver and Nsight (I cannot remember exactly their numbers) and the debugging was successfully worked.

I tried to increase the TDR (above then 10) and also activate the VS and\or Nsight monitor as an administrator but these steps didn’t help.
Any advise will be much appreciated,

Thanks

Hi, sorry for the late response. Yes, I solved my issues. My issues where caused by a incompatible motherboard BIOS. The system ran, but CUDA wasn’t able to properly function with this motherboard BIOS version, updating the motherboard BIOS fixed my issue.