Cuda/ nvcc not found


I bought a jetson nano development kit few days ago. I followed the quick start guide to have ubuntu and jetpack on the nano via an image on a microSD card.

Do I have to do something after this guide? To install CUDA for example? Because the command nvcc doesn’t work and if I want to install and compile darknet, it says CUDA is not found.


1 Like

If you used the Nano SD card image, then yes, it already has the CUDA Toolkit installed. Check under /usr/local/cuda to verify that it’s there.

Check that your ~/.bashrc file has these lines at the end, and if not, add them and restart your terminal:

$ export PATH=/usr/local/cuda/bin${PATH:+:${PATH}}
$ export LD_LIBRARY_PATH=/usr/local/cuda/lib64\

…nevermind…didn’t see the “+:” in the statement. Was thinking the “:” was missed but it wasn’t.

It might be a good idea to modify /etc/skel/ on the rootfs to add this by default. .profile might be a good place to put it. It’s evaluated before .bashrc and runs for any shell (or whatever). It’s where Canonical (and Debian) puts modifications to $PATH.


Hi, wich bashrc do you speak of? the one hidden in my home directory?
I use jetpack 4.3, just to understand, is this normal that it is not already linked?

With the path added it worked thanks! But to be sure everythings is still working, when I compile with darknet, I get this message :
darknet is fine for now but uselib_track has been disabled!
please rebuild opencv from sources with cuda support to enable it

I did have this problem on Windows, but on linux I’m not sure how to handle this problem.

1 Like


It looks like the darknet frameworks requires a GPU version OpenCV.
The package installed from JetPack doesn’t enable the GPU support.

You can built it from source with this script:

If the error continues, would you mind to file a new topic that specified for OpenCV?


1 Like


It says that the script cannot be found
Are there any other scripts I can use?

Thank you.