CUDA toolkit install problem on Jetson TK1

I followed the instructions on here http://elinux.org/Jetson/Installing_CUDA to install CUDA to the TK1, and everything went smoothly. The CUDA toolkit is install and I completed bash login script edit. I restarted the board and it when I run the nvcc -V command I get “bash: nvcc: command not found”

When I change the directory in terminal to the location “/usr/local/cuda/bin” and run it again I still “command not found”

I can see that it is clearly there in the directories.

Has this happened to anyone? I have seen some people install Ubuntu 13.04 version rather than the L4T one. Is that a better option?

You probably need to set your PATH variable.

Even if you change to the directory where the nvcc executable is located, if that directory is not on your PATH, you cannot run it by typing:

nvcc

you could probably run it by typing

./nvcc

but the right thing to do is to set your PATH variable correctly. If you think you edited your bash login script to do this, then I would say something is wrong there. Try:

echo $PATH

and see what is reported.

Ahh. I have cudo-6.0 That would be the problem. Its been a few years since I have been in Ubuntu so I am still getting used to it again. Didn’t think to echo it out.

Now the problem is how do I remove the bad path from the $PATH variable

Nevermind. I got it. Thanks.