How to emulate cuda without GPU

I am using Ubuntu 9.04 (32bit). I have successfully installed cuda toolkit 2.3 and sdk in my laptop and also set the PATH and LD_LIBRARY_PATH. Since I don’t have a cuda-enabled gpu (my video card is integrated), I want to emulate cuda through “make emu=1”. But it seems this does not work for me at all. One thing is it seems the system cannot locate nvcc correctly, since when I type “nvcc”, it shows like this:

/usr/local/cuda/bin/nvcc: No such file or directory

But the nvcc file does locate in the folder and the I think the environment variables are set correctly. I totally cannot figure out why is that. Can anyone help me with this?

add /usr/local/cuda/bin to the PATH environment variable

can do it by editing bash_profile or bash_rc I believe

This can also happen if you have the 64-bit binaries installed on a 32-bit machine (or vice versa without 32-bit compatibility enabled) by accident. Are you sure you installed the right package?

That probably won’t help. The makefile already has the full path to the compiler and it is reporting it can’t find it. My guess is that the CUDA SDK has been installed somewhere other than /usr/local. The original poster will need to edit the SDK file to include the correct path to the SDK installation, something like this:

.SUFFIXES : .cu .cu_dbg.o .c_dbg.o .cpp_dbg.o .cu_rel.o .c_rel.o .cpp_rel.o .cubin .ptx

# Add new SM Versions here as devices with new Compute Capability are released

SM_VERSIONS := sm_10 sm_11 sm_12 sm_13

CUDA_INSTALL_PATH ?= /opt/cuda

or define the CUDA_INSTALL_PATH variable to point to the root path of the SDK installation.

Hi All,

i have developed a simple cuda program. i dont have a GPU in my system.
my program consist of only a single .cu file. i am able to successfully compile it and run it. But the kernel does not get executed.
what could be the reason.

Check the error code after launching the kernel.