Cuda problem in andriod, please help!

hello,
I am presently using nvidia TK1 platform. And i want to use cuda6.5 at andriod4.4
Now I have successfully generated a .so file. However, calling cudaGetDeviceCount returns 35. I have downloaded the codewords for android comes with sample (using the 7.0 sdk). Some samples can be used on my device; part samples tips gpu or driver does not support. I’ve been through Codeworks for andriod installed the driver, but I’m not familiar with andriod, I do not know whether the driver has been successfully enabled.

My question is:
1, Does k1 supports cuda in andriod? If so, whether there are requirements for the release?
2, for the cuda driver: Whether the system needs to be changed so that the driver can start

Overall: how to successfully call cudaGetDeviceCount at andriod(TK1 platform).

Please help me! thx very much !!

So far as I’ve seen TK1 was never officially supported under Android. There are unofficial Android ports, but I doubt these ports support CUDA. Official Android support exists for the Shield, but I don’t think even the TX1 has Android support (despite Shield support). A successful hardware access for anything GPU would likely require using the nVidia-specific files from the apply_binaries.sh script.

hey linuxdev, Thank you for your answer! I learned a lot!

You mean the official did not provide andriod version for TK1 even tx1. Andriod unofficial version is perhaps not support cuda.
But I saw some folders(…/NVPACK/cuda-android-7.0) from the tool provided in the official (CodeWorks for Andriod)

more question:
1, which NVIDIA’s board can use the above folder? Without board support, why these folders exist?
2, If there is no official support of the board, but I still insist on using cuda at Andriod! Does that mean I have to modify apply_binaries.sh, may be I can successfully use cuda. right?
3, In addition, I found that I was unable to compile the sample provided by the official.
here: (call import-add-path, (NVPACK) / Samples / TDK_Samples / libs / jni), I can not find TDK_Samples folder. Do you know why?

Expect to get your answer, thanks again!!

Correct…all Android support for Jetson TK1/TX1 is from third parties. Android support is direct for Shield. In the case of L4T (Linux Ubuntu), files from the apply_binaries.sh script are direct hardware access versions which add to or replace the Ubuntu versions, which in turn makes hardware acceleration and CUDA possible.

I don’t know enough about Android ports to know what would be required to use the hardware-accel versions of L4T there…perhaps it is possible, someone who has tried may be able to give more insight on this.

I have not tried the samples in a very long time, but some of them may try to compile even if not meant for that platform…I can’t really test anything run from JetPack because I don’t have an Ubuntu desktop host (and my Fedora host has dead hardware for now).

Some of the CUDA forums may have more traffic regarding the CUDA questions, I’d suggest adding your questions here:
https://devtalk.nvidia.com/default/board/58/cuda-setup-and-installation/

Well, the problem seems very difficult.
linuxdev, Thank you for your answer, I’ll try to resolve it.