Cuda setup fails of Win 7 x64

First time I successfully installed CUDA, but I hadn’t MS VS. Then I removed cuda and installed MS VS 2013 community. And then I tried to install cuda 7.5. Installation faied immediately after start. And I saw this
“Sorry, I don’t know how to achive installation in english, but I hope it obvious even in russian”

No “system requirements check” or “licence agriement” steps were performed. I saw this window immediately after start. Same story for netinstall and local install for cuda since 6.5 version till 7.5. I tried to make logs
setup.exe -log:“C:\path” -loglevel:6, but unsuccsefully.

PS. Nvidia 740M

Probably, you can try a clean installation…

  • removed all NVIDIA software from control panel;
  • reboot system;
  • reinstall cuda 7.5 production installer cleanly;

Hope it helps.

I tried this several times. Also I tried driver clean tools. I’m interested, how to make installer write some logs?

I tried ‘setup.exe -log:“C:\NVlog” -loglevel:6’ with cuda7.5prod(7.5.18) on one Win7/x64 box.There finished with log generated/retained under the specified path.