CUDA Toolkit 9 is not available in Geforce MX150

My graphics hardware is Geforce MX150, and when I intalled CUDA Toolkit 9, it said "This graphics driver could not find compatible graphics hardware. You may continue installation, but you may not be able to run CUDA applications with this driver. This may occur with graphics hardware that is newer than this toolkit. In that case, it is suggested that you keep your existing driver and install the remaining portions of the CUDA Toolkit. "
Does somebody know how to solve this problem?
Thank you!

I have the same question. MX150 is the notebook version of GT1030 and the two ones are not in the cuda-enabled GPU list now. Can they be changed to cuda-enabled ones in the future ?

I am looking into a laptop with a MX150, does anyone knows if it is compatible with CUDA 8.0 and cuDNN v5.1+?

I have tried to look for it in the CUDA supported GPUs list at https://developer.nvidia.com/cuda-gpus but I couldn’t find the MX150, although in the MX150 page at https://www.geforce.com/hardware/notebook-gpus/geforce-mx150, CUDA is listed as a supported technology, could it be that the CUDA supported GPUs list was not updated yet?

Any updates on the CUDA support?
@jaoplmpereira , if CUDA Toolkit 9 doesn’t support it as of now, I doubt 8.0 will support it

Are there any official statements why there we don’t have support for CUDA Toolkit?

I am also interested in this problem. I have a Geforce MX 150 and want to install cuda and cudnn. Nvidia`s site seems to imply that it is cuda capable here
https://www.geforce.com/hardware/notebook-gpus/geforce-mx150/specifications
But it is not listed in the supported gpus here:

joaoplmpereira has already mentioned this, but since it still has not been explained, I reiterate.

Hey guys, I have solved this problem.

I updated graphics driver to the newest version. And I installed CUDA Toolkit 9.1 form here.

Well, I think NV Corp added the support of MX150 in Toolkit 9.1

1 Like

I got it working on a MX150 with python 3.6 (64 bit) installed a precompiled wheel from https://github.com/fo40225/tensorflow-windows-wheel/tree/master/1.5.0/py36/GPU/cuda91cudnn7avx2

And CUDA 9.1 and CUDNN 7.0.5

I got Acer Aspire 5 recently with MX150. I could successfully install Cuda 9.1 on Ubuntu 16.04. Struggled initially but if you manage your secure boot option carefully, rest is same as the standard cuda installation.

Successfully installed Cuda 9.1 on my Xiaomi Notebook Pro containing an MX150 as well
Built Tensorflow forom source using cudnn 7 and everything works perfectly!

NVIDIA hasn’t updated their documentation yet but I can also confirm Cuda 9.1 works!

What about MX 130… Which cuda version does it support…?

Hi guys, have you tried use the MX150 to decode video? I found the MX150 with the cuda9.2 also can’t use the cuvid. This disgusts me.

Hi guys I had the same issue and I have the same GPU which is MX150 and I saw your solution , actually it worked out for me so now I can import tensorflow perfectly but I have a little error which is:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\Users\MHD\Anaconda3\envs\tf_15\lib\site-packages\tensorflow\python\client\session.py", line 1509, in __init__
    super(Session, self).__init__(target, graph, config=config)
  File "C:\Users\MHD\Anaconda3\envs\tf_15\lib\site-packages\tensorflow\python\client\session.py", line 628, in __init__
    self._session = tf_session.TF_NewDeprecatedSession(opts, status)
  File "C:\Users\MHD\Anaconda3\envs\tf_15\lib\site-packages\tensorflow\python\framework\errors_impl.py", line 473, in __exit__
    c_api.TF_GetCode(self.status.status))
tensorflow.python.framework.errors_impl.InternalError: Failed to create session.

[b]CUDA toolkit version 9.1
cudNN version 7.0.5
tensorflow-gpu version 1.5.0

Hello guys I have laptop with mx150 graphics card and I am trying to install tensorflow gpu on windows 10, I have attempted to install it using the searchable tutorials but it did not work, can you please help me on how to install it on windows 10 pleaseee