Is GeForce MX150 CUDA enabled?

If so is there any mix (tensorflow, nvidia driver, cuda driver, cudnn) of versions I should follow?

I have tried with cuda 10.0, and 10.1 with tensorflow 1.13.1 and for both I get

ImportError: libcublas.so.10.0: cannot open shared object file: No such file or directory

Then I tried CUDA 10.0 with tensorflow 1.13.0rc2 and tensorflow-gpu of equal version, and got no errors but device_lib kept showing only CPU:0, and no GPU.

Mine is an NVidia GeForce MX150. Already asked support to confirm wether it is CUDA enabled or not. They addressed me here.

Many thanks for your help.

Carlos.

The MX150 can run cuda, the only thing it’s missing is hw accellerated video encoding.
Which distro are you using?
How did you install the driver?
How did you install cuda?
What’s the output of the deviceQuery sample?
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Thanks I could finally install it.
In fact it was installed, in python console I could get it to work inmediately. The problem was PyCharm. I am quite newbie in this whole architecture and was missing creating the env variable in the run configuration in pycharm.

Many thanks for your support.

Anyway to whom it may help a definitive guide to install this in Ubuntu has been this link:

Best regards,

Carlos Conti.