CUDA version is insufficient for CUDART version

Got this error while running CUDA program on Ubuntu 9.10, cuda 2.3. Any ideas?
The error comes in cutil.h functions.

What driver version are you using?


I do have exactly the same problem, when I try to run the samples: : cudaSafeCall() Runtime API error : CUDA version is insufficient for CUDART version.

I’m running Cuda 3.0 under Ubuntu 9.10 64bits, with the Nvidia driver 190.53 (my graphic cards are two Quadro FX4800).

I know there are some issues with the fact that Ubuntu 9.10 runs on gcc 4.4.3, so I used the workaround I found on the forum, which consists of commenting some lines in the math_functions.h and common_functions.h files. (the one with __signbit* and memcopy + memstr). The samples compile then just fine, but still I cannot run them.

Any hint? I spent some time just compiling Cuda, apparently I’m not done with surprises :sweat:

Damn GCC 4.4.3!! :pirate:

Cuda 3.0 requires 195 series (or later) drivers. Won’t work with 190 series.

Thanks for your quick answer, I’ll try that right away!

EDIT: Yep, it works perfectly now. However I had to disable Xinerama, because it gives me an “unknown error”. Not a big deal though. Thanks again for your help avidday!