Cuda working before then no CUDA-capable device detected

Hi. I was previously running cuda and cublas successfully on my laptop and within the last two weeks but then something went wrong. I am running 64-bit windows 8.1 with an NVIDIA Geforce GT 640M LE GPU. Everything was previously working using Visual Studio 2010 (unsure of the GPU driver installed when working, but I could find out if explained how). Then, yesterday I tried to run a program again for the first time in about 2 weeks and it ultimately boiled down to the no CUDA-capable device detected in deviceQuery.

Here’s what I’ve tried, without any changing behavior(in order):
Uninstall/Reinstall Cuda
Clean Reinstall GPU driver (both newest and second newest drivers)
Tried running Cuda-z but no cuda-capable device detected
Tried all of the above again in varying orders (getting desperate)
Windows System Reset to a week ago (that’s the oldest reset available)
Installed MS VS 2013
Clean Reinstall of GPU driver

I have almost the exact same problems and behaviors as described here:
but I really don’t know if I could afford to do a whole reinstall of my OS because it would take at least a few days getting all my software reinstalled and things back to normal…

I haven’t tried to physically remove the graphics card, nor do I even know how to/if I should do that because I’m not that tech savvy with GPUs and I’m 4 weeks new to CUDA.

Please let me know if you have any other suggestions.


Also, here’s an output from running nvidia-smi

C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi
Thu Jul 09 09:00:19 2015
| NVIDIA-SMI 353.30 Driver Version: 353.30 |
| GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GeForce GT 640M LE WDDM | 0000:01:00.0 N/A | N/A |
| N/A 43C P0 N/A / N/A | 61MiB / 2048MiB | N/A Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| 0 Not Supported |

C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi -a

==============NVSMI LOG==============

Timestamp : Thu Jul 09 09:03:31 2015
Driver Version : 353.30

Attached GPUs : 1
GPU 0000:01:00.0
Product Name : GeForce GT 640M LE
Product Brand : GeForce
Display Mode : N/A
Display Active : N/A
Persistence Mode : N/A
Accounting Mode : N/A
Accounting Mode Buffer Size : N/A
Driver Model
Current : WDDM
Pending : WDDM
Serial Number : N/A
GPU UUID : GPU-66ca17fa-c833-92d0-445f-e2d97bdfd548
Minor Number : N/A
VBIOS Version : 80.07.4A.00.06
MultiGPU Board : N/A
Board ID : N/A
Inforom Version
Image Version : N/A
OEM Object : N/A
ECC Object : N/A
Power Management Object : N/A
GPU Operation Mode
Current : N/A
Pending : N/A
Bus : 0x01
Device : 0x00
Domain : 0x0000
Device Id : 0x0FD310DE
Bus Id : 0000:01:00.0
Sub System Id : 0x909C104D
GPU Link Info
PCIe Generation
Max : N/A
Current : N/A
Link Width
Max : N/A
Current : N/A
Bridge Chip
Type : N/A
Firmware : N/A
Replays since reset : 0
Tx Throughput : N/A
Rx Throughput : N/A
Fan Speed : N/A
Performance State : P0
Clocks Throttle Reasons : N/A
FB Memory Usage
Total : 2048 MiB
Used : 61 MiB
Free : 1987 MiB
BAR1 Memory Usage
Total : N/A
Used : N/A
Free : N/A
Compute Mode : Default
Gpu : N/A
Memory : N/A
Encoder : N/A
Decoder : N/A
Ecc Mode
Current : N/A
Pending : N/A
ECC Errors
Single Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Double Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Single Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Double Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Retired Pages
Single Bit ECC : N/A
Double Bit ECC : N/A
Pending : N/A
GPU Current Temp : 42 C
GPU Shutdown Temp : N/A
GPU Slowdown Temp : N/A
Power Readings
Power Management : N/A
Power Draw : N/A
Power Limit : N/A
Default Power Limit : N/A
Enforced Power Limit : N/A
Min Power Limit : N/A
Max Power Limit : N/A
Graphics : N/A
SM : N/A
Memory : N/A
Applications Clocks
Graphics : N/A
Memory : N/A
Default Applications Clocks
Graphics : N/A
Memory : N/A
Max Clocks
Graphics : N/A
SM : N/A
Memory : N/A
Clock Policy
Auto Boost : N/A
Auto Boost Default : N/A
Processes : N/A

Maybe you have an optimus laptop and the NVIDIA GPU is not powered up. Check to see if there are any BIOS settings that will force the NVIDIA GPU to stay on.

I checked my BIOS and the only relevant GPU setting was “Discrete Graphics Card” which was enabled and changing it to disabled didn’t do anything. I also edited my original post to add some nvidia-smi output. I’m not sure if I have NVIDIA Optimus but it doesn’t look like it.

Well, I fixed it. It occurred to me to that it was certainly a hardware issue, but I just couldn’t figure out what I was doing wrong. Then I remembered I recently tried to save power usage on my laptop during a plane flight and flipped this switch on my keyboard from “speed” to “stamina” on my vaio. In my defense, I’ve literally only used that feature once in the whole three years I’ve had this laptop… Anyways, I just switched it back, ran device query and concluded by yelling some colorful words (or twenty) while kicking myself. Four days wasted on switching a tiny little button.

Hopefully someone out there will find this post useful.

Great Suggestion. I spent lot more than few weeks and multiple tech support people to resolve this and in the end Stamina/Speed switch fixed it .