Quadro K1000M device not found

I am attempting to setup a windows computer (Dell precision 4700) for cuda development. I am using cuda 5.5 because I have source code that was built against that version of the toolkit.

After installation I could not run the software so I tried to verify everything was set up correctly by testing some of the SDK apps. Starting with Device Query I receive “error 38 no cuda-capable device is detected”.

There is a nvidia quadro K1000M in the laptop but cuda is not finding the device. Any suggestions?

It’s an optimus laptop, meaning it has both an Intel (integrated) GPU and the discrete K1000M.

See if the optimus documentation helps:

http://docs.nvidia.com/cuda/optimus-developer-guide/index.html#abstract

You should also refer to the windows getting started guide:

http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-microsoft-windows/index.html#abstract

It may also be useful for test purposes only, to disable Optimus in the BIOS. Then re-run your test, they should work at that point. But it’s recommended that you follow the instructions in the optimus guide above.

Thanks for the response. I disabled Optimus in the BIOS and ran Device Query again and receive the same error “error 38 no cuda-capable device is detected”.

What should I try next?

which GPU driver is installed?

with optimus disabled, run

nvidia-smi -a

from a elevated command prompt

The following contains the NVSMI Log.

==============NVSMI LOG==============

Timestamp : Wed Jul 23 15:12:46 2014
Driver Version : 340.52

Attached GPUs : 1
GPU 0000:01:00.0
Product Name : Quadro K1000M
Product Brand : Quadro
Display Mode : Enabled
Display Active : Enabled
Persistence Mode : N/A
Accounting Mode : Disabled
Accounting Mode Buffer Size : 128
Driver Model
Current : WDDM
Pending : WDDM
Serial Number : N/A
GPU UUID : GPU-e7f72658-71da-3002-0aec-3a849393cf1f
Minor Number : N/A
VBIOS Version : 80.07.40.00.03
MultiGPU Board : No
Board ID : 0x100
Inforom Version
Image Version : N/A
OEM Object : N/A
ECC Object : N/A
Power Management Object : N/A
GPU Operation Mode
Current : N/A
Pending : N/A
PCI
Bus : 0x01
Device : 0x00
Domain : 0x0000
Device Id : 0x0FFC10DE
Bus Id : 0000:01:00.0
Sub System Id : 0x053E1028
GPU Link Info
PCIe Generation
Max : 2
Current : 1
Link Width
Max : 16x
Current : 16x
Bridge Chip
Type : N/A
Firmware : N/A
Fan Speed : N/A
Performance State : P8
Clocks Throttle Reasons : N/A
FB Memory Usage
Total : 2047 MiB
Used : 2007 MiB
Free : 40 MiB
BAR1 Memory Usage
Total : 256 MiB
Used : 38 MiB
Free : 218 MiB
Compute Mode : Default
Utilization
Gpu : 0 %
Memory : 4 %
Encoder : 0 %
Decoder : 0 %
Ecc Mode
Current : N/A
Pending : N/A
ECC Errors
Volatile
Single Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Double Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Aggregate
Single Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Double Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Retired Pages
Single Bit ECC : N/A
Double Bit ECC : N/A
Pending : N/A
Temperature
GPU Current Temp : 42 C
GPU Shutdown Temp : 104 C
GPU Slowdown Temp : 96 C
Power Readings
Power Management : N/A
Power Draw : N/A
Power Limit : N/A
Default Power Limit : N/A
Enforced Power Limit : N/A
Min Power Limit : N/A
Max Power Limit : N/A
Clocks
Graphics : 135 MHz
SM : 135 MHz
Memory : 405 MHz
Applications Clocks
Graphics : N/A
Memory : N/A
Default Applications Clocks
Graphics : N/A
Memory : N/A
Max Clocks
Graphics : 850 MHz
SM : 850 MHz
Memory : 900 MHz
Clock Policy
Auto Boost : N/A
Auto Boost Default : N/A
Compute Processes
Process ID : 4
Name : Insufficient Permissions
Used GPU Memory : Not available in WDDM driver model
Process ID : 528
Name : C:\Windows\system32\Dwm.exe
Used GPU Memory : Not available in WDDM driver model

With Optimus disabled in the BIOS, can you:

  1. try to reinstall the driver, selecting “clean install” as discussed here:
    http://nvidia.custhelp.com/app/answers/detail/a_id/2900/~/guide-on-how-to-install-the-nvidia-display-driver-under-windows-7%2Fwindows-vista

  2. Then reinstall the CUDA 5.5 toolkit, while deselecting the option to install the driver (from the toolkit installer)

  3. Try the deviceQuery test again.
    ?

Still no luck.

Since I continue to get no “cuda-capable device is detected” does this imply there this is a driver issue or are there any other possibilities?

Where did you get the driver (340.52)?

Can you try installing CUDA 6 instead of CUDA 5.5 for test purposes? See if there is any difference in behavior.

When CUDA 5.5 did not work I tried CUDA 6 which also did not work. At this point I have both toolkits installed and can change CUDA-PATH to test appropriately.

I tested the each development driver with the associated version of the driver and neither worked. Then I tested the Dell driver with both version which also did no work. Additionally I ran device query using the driver API which returns error 100 on cuInit.

I am not sure of the next debug step. I wanted to revert to an older Dell driver but they are not available on the website.

when you go into device properties, how many display adapters are listed? Is it just the NVIDIA adapter, or is the intel adapter listed also? Are there any yellow bang symbols or warnings?

Which Windows OS is on that laptop?

For test purposes, would it be possible to attach an external display to the laptop, and configure your windows desktop to extend onto that display? And then re-run the test.

This appears to be the most recent Dell driver for that laptop:

http://www.dell.com/support/drivers/us/en/19/DriverDetails?driverId=X86RM

However, I’m not suggesting you install that one. I don’t believe it is compatible with either CUDA 5.5 or CUDA 6.0.