cudaImportExternalMemory failed on rgbImage

I am facing a weird error. Whenever I call gym.create_camera_sensor(env, camera_props), I get an error: [Error] [carb.gym.plugin] cudaImportExternalMemory failed on rgbImage buffer with error 999.

I am trying to get the RGB images from unitree a1 environment in this repo: (GitHub - leggedrobotics/legged_gym: Isaac Gym Environments for Legged Robots).

Even if I try to run the interop_torch.py example then also the same error comes up.

I encountered the same problem with RTX3070, Ubuntu 20.04, did you solve it?

If you are getting the same error while running the interop_torch.py then delete your conda installation try installing conda with py3.7 as the base and then try to install the issacgym environment (which I did and it worked, as my initial conda base env was with python3.8). By the way, issacgym recommends ubuntu 18.04 so if this solution does not work then you might have to install ubuntu 18.04. For me this error was generated in pop-os 20.04 with conda base as python-3.8.

1 Like