cuvidCreateDecoder failed with CUDA_ERROR_INVALID_VALUE

Every things goes well When I load a 1K x 1K mp4 video by using cuda decode video sample.
But when load 2K x 2K resolution mp4 video, the result = cuvidCreateDecoder(), return CUDA_ERROR_INVALID_VALUE.
And, I have test that the cuda sample can load some 2k resolution videos some times.
So, is some limitation about video for cuda decode?

Which nVidia GPU are you using?

GTX1050 and GTX1080

It should be no problem. Can you point us to the sample code you are using and give a link to the problematic video?

The sample named cudaDecodeGL in CUDA Samples v9.1 Imaging.

I can’t upload the mp4 video because the HTML do not support…

Please put it on a hosting site and post the link here.

We have to be able to recreate your issue.

Can I send the video by e-mail?

How big is it?

11.8MB

Probably too big.

You can google ‘file upload sites free’ and learn how to use one. Then upload the link here.

Yep…
I tried upload the video to my github.

OK, then what is the link to it?

vimeo is not a file hosting site. It usually re-encodes the video. In any case, you do not have downloads enabled, probably because you made only a basic account.

When you have a way for me to download the unprocessed source file, please advise.

Hint: filedropper, dropbox, etc.

Thank for your help.I feel so sorry…

I upload video to youtube and Link: https://youtu.be/oLlDDss6jQs

And if it is not useful, is it possible send the video by g-mail? I find I can upload the video to g-mail…

Where is the download button on a youtube video? And again, youtube is not a file hosting site and very often re-encodes video.

Use this:
http://www.tinyupload.com/

And you mentioned that the file is MP4, but the decode sample wants an elementary stream. So how are you demuxing the elementary stream from the MP4?

If you are trying to use the MP4 file directly, this may be the cause of your difficulties.

http://s000.tinyupload.com/index.php?file_id=26873299573370896226

yep.
But it’s ok when I load some 1024x1024 resolution MP4 video files directly.

And if the codec can’t decode the 2kx2k MP4 files, is it that codec can not decode the same MP4 file only with different resolution?
But, I tried the video I uploaded. Load 2kx2k failed, but 1k x 1k succeed…Why?

Please upload the 1kx1k file also and give the link.

EDIT: no need for this (see below).