DDA Error Code 43 P4000

Hi

We use a Nvidia Quadro P4000 on a HPE DL380 Gen10 with Windows Server 2016 Hyper-V and Passtrough the Card with DDA to a Windows Server 2016 VM.

W’ve installed the latest drivers. But after a while, without any user input, the card shows the error code 43.

I’ve the exact same problem on HPE DL380 hardware. I reached out to Microsoft and they claim that the driver is causing the error and shutting down the card.

So there isn’t a solution for this Problem?

First of all you should specify which driver you are using and if this happens also with vGPU drivers for example.
Be aware that there is no software support for this configuration and you would need to deal with the OEM first that supports running P4000 in server hardware (instead of Tesla).
In addition I’ve not heard of any issues with other hypervisors running the same config so MSFT’s response is not what I would expect.

I’ve since tried both a VM with server 2012R2, I used this driver for that machine: 411.63-quadro-tesla-grid-winserv2008r2-2012-2012r2-64bit-international-whql

And for the other VM with server 2016 I used driver: 411.63-quadro-winserv-2016-64bit-international-whql

Both with same result. If I install it directly on the hardware the card works fine.

Is it a possibility that the driver picks up different values from a VM in Hyperv vs Xen and ESXi?

The latest driver i’ve used was this one: 411.63-quadro-winserv-2016-64bit-international-whql

I would assume this is DDA related. Could you check your settings with MSFT:
https://docs.microsoft.com/en-us/windows-server/virtualization/hyper-v/deploy/deploying-graphics-devices-using-dda

There are a lot of different settings you can do to improve the performance/quality with DDA.

Regards

Simon

I’m sorry to hijack Uetendorf thread but like I’ve said before I was in contact with Microsoft and gave them my whole setup with the specifics of the virtual machine and their only response was that it’s the driver that’s causing the error.

I don’t know if it’s DDA or the driver but you said earlier that this should work, but is Hyper-V and DDA supported by Nvidia?

There is no official support for DDA with Quadro because it is not a tested configuration. For Virtualization we have Tesla boards and our vGPU software stack. I’m running DDA with a Tesla M10 without any issues.

We allow to run Quadro boards >2000 series in a virtualized environment but there is no support. Some customers are running Quadro instead of Tesla to avoid licensing costs. It should work but there is no guarantee and it is on our own risk.
As I said earlier I’m not aware of any specific issues with other hypervisors and we only have a single driver so I still believe this is MSFT related.

Thank you very much, I don’t like the idea to use unsupported solutions so I’ll reconsider my hypervisor options.

Again, thank you for your support and quick responses.

When you specify >2000 do you mean 2000 cards (K2000, P2000?) do not work (only 4000 and up), or the 2000 series as a minimum? I kinda guess if 2000 work you could have written >=2000, but just for extra clarification.

Thanks

starting with 2000er series and up to be clear :)