Deepstream 2.0 cannot create few elements in the sample apps

Hi,

We are trying out the provided samples for Deepstream 2.0, and they compile fine, but fails to create certain gstreamer elements. To my best understanding, the provided pre-compiled libraries for gstreamer have been expanded to /usr/lib, etc folders.

These are the missing ones for test1-app:
pgie

These are the missing ones for test2-app:
pie
nvtracker
sgie1
sgie2
sgie3

Please help on how to get these to be “discovered” properly/correctly.

Regards,
Anup

Hi,

Here are some dependencies:

• Ubuntu 16.04
• Gstreamer 1.8.3
• NVIDIA driver 396+
• CUDA 9.2
• TENSORT 4.0
• OpenCV 3.4.x

Please make sure you have set-up the required package first.
Thanks.

Hi, All dependencies are in place as per your list and the documentation. Any pointers on what to look for based on the error will really help.

Hi,

Have you followed our README to set up the environment?

[i]--------------------------------------------------------------------------------
Extract and Install DeepStream SDK

  1. This package will have binaries.tbz2 and samples directory.
  2. Untar binaries.tbz2
    sudo tar -xvf binaries.tbz2 -C /
  3. Add LD_LIBRARY_PATH=/lib/:LD_LIBRARY_PATH in {HOME}/.bashrc
    [/i]
    Thanks.

Hi,

Yes, I have followed. In case your engineers can point to a particular file/module that might be missing, it will help me debug in case I have messed up its placement, etc.

Regards,
Anup

Hi,

Is the deepstream-app working on your environment?
Or issue is only related to deepstream-test1 and deepstream-test2?

deepstream-app -c <path to config.txt>

Thanks.

Hi Anup,

Have you managed to get the deepstream-app running on your environment?
Is this still an issue to support?

Thanks

Hi kayccc,

We have got it working. Needed some re-installation, but also making sure that only the Tesla GPUs were exposed to it, unlike Deepstream 1.0 which would work on any Pascal GPU.

Regards,
Anup