DS 2.0, test1_app: GST_MESSAGE_NEED_CONTEXT

On Ubuntu 16.04 Azure VM, DeepStream 2.0, trying to run deepstream_test1_app. Get GST_MESSAGE_NEED_CONTEXT which is not handled, so the app freezes.

Source of the message: “nvvideo-renderer”

Here is a screenshot:

https://www.dropbox.com/s/d3lrfxsuo3ffd6u/need_context.png?dl=0

HI,
I can run well with this deepstream version 2.0, here is my environment: server with ubuntu 16.04, RAM 128G,
gpu: tesla p4; can you elaborate your environments?

V100, 112 GB RAM. XFCE desktop. I suspect it’s GStream installation. It doesn’t look healthy, cannot find plugins… If you run gst-inspect-1.0 h264parse, does it find it?

yeah, i have this plugin, below is the details. can you follow README from here: binaries.tbz2 docs LicenseAgreement.pdf readme README samples sources usr
to resetup your environments? besides, please install: sudo apt install libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libglew-dev libssl-dev libopencv-dev freeglut3-dev libjpeg-dev libcurl4-gnutls-dev libjson-glib-dev libcairo2-dev libpango1.0-dev libfontconfig1-dev libfreetype6-dev libpng-dev libgles2-mesa-dev libegl1-mesa-dev
and try again.

Factory Details:
Rank primary + 1 (257)
Long-name H.264 parser
Klass Codec/Parser/Converter/Video
Description Parses H.264 streams
Author Mark Nauwelaerts mark.nauwelaerts@collabora.co.uk

Plugin Details:
Name videoparsersbad
Description videoparsers
Filename /usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstvideoparsersbad.so
Version 1.8.3
License LGPL
Source module gst-plugins-bad
Source release date 2016-08-19
Binary package GStreamer Bad Plugins (Ubuntu)
Origin URL https://launchpad.net/distros/ubuntu/+source/gst-plugins-bad1.0

GObject
±—GInitiallyUnowned
±—GstObject
±—GstElement
±—GstBaseParse
±—GstH264Parse

Pad Templates:
SINK template: ‘sink’
Availability: Always
Capabilities:
video/x-h264

SRC template: ‘src’
Availability: Always
Capabilities:
video/x-h264
parsed: true
stream-format: { avc, avc3, byte-stream }
alignment: { au, nal }

Element Flags:

Nothing worked until I added:

GST_PLUGIN_PATH="/usr/lib/x86_64-linux-gnu/gstreamer-1.0"

to .bahrc. At least now I can build the same pipeline manually and see what is not working. Thanks for your help.

Hi Amycao and Fierval,
I am trying to compile deepstream2 for Tesla p4s and its giving me Gstreamer error;

Here is the error;

Error from secondary_gie_bin_queue: Internal data flow error.
Debug info: gstqueue.c(992): gst_queue_handle_sink_event (): /GstPipeline:pipeline/GstBin:secondary_gie_bin/GstQueue:secondary_gie_bin_queue:
streaming task paused, reason not-negotiated (-4)
Quitting

Its a Ubuntu 16.04 system with 2x P4, Cuda 9.2, Tensorrt 4, Opencv, FFmpeg compiled from binaries and with no errors during compilation.

I have installed and later reinstalled the gstreamer as per the guide. But no luck! Tried removing the gstreamer.bin in the cache as well. No luck!
It will be really helpful if you can provide insight to the same.

(cuda and the drivers are installed with the --noopenglflags to make sure that the display(Xorg) is not breaking)

Can you tell me how exactly you have installed the system?

similar topic at https://devtalk.nvidia.com/default/topic/1041720/deepstream-for-tesla/deepstream2-0-samples-is-not-getting-compiled-it-shows-some-failure-due-to-gstreamer-/?offset=2#5284519, let’s discuss there.

Sure:)