Deepstream 5.1 raising the error gst_element_factory_make: no such element factory "nvstreammux"!

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU): Jetson TX2
• DeepStream Version: 5.1
• JetPack Version (valid for Jetson only): 4.5.1 (installed from sdkmanager)
• TensorRT Version: 7.1.3-1+cuda10.2
• Issue Type( questions, new requirements, bugs): question

I’m trying to run an application based on deepstream-test2 on Jetson TX2 and I’m facing the error:

nvbuf_utils: Could not get EGL display connection
nvbuf_utils: ERROR getting proc addr of eglCreateImageKHR
nvbuf_utils: ERROR getting proc addr of eglDestroyImageKHR

So, I set the GST_DEBUG to get more details and I got the following message:

0x55a51764f0 WARN     GST_ELEMENT_FACTORY gstelementfactory.c:456:gst_element_factory_make: no such element factory "nvstreammux"!
One element could not be created. Exiting.

I already tried all suggestions of all other posts on the Nvidia forum without success. Such as: changes on the DISPLAY env variable; check if the nvgpu module is loaded; check all EGL, GL, and GLU libs; and Set the application to run on a fake sink;

It’s important to comment that I ran the same application on Jetson Nano 4GB with Jetpack 4.4.1 with success.

What is the result when you run “gst-launch-1.0 nvstreammux”?

The result is:

0:00:00.000201821 17501 0x559b121c00 INFO GST_INIT gst.c:586:init_pre: Initializing GStreamer Core Library version 1.14.5
0:00:00.000317851 17501 0x559b121c00 INFO GST_INIT gst.c:587:init_pre: Using library installed in /usr/lib/aarch64-linux-gnu
0:00:00.000409338 17501 0x559b121c00 INFO GST_INIT gst.c:607:init_pre: Linux image-box 4.9.201-tegra #1 SMP PREEMPT Tue Mar 2 19:53:23 PST 2021 aarch64
0:00:00.001154224 17501 0x559b121c00 INFO GST_INIT gstmessage.c:127:_priv_gst_message_initialize: init messages
0:00:00.002580987 17501 0x559b121c00 INFO GST_INIT gstcontext.c:84:_priv_gst_context_initialize: init contexts
0:00:00.003348496 17501 0x559b121c00 INFO GST_PLUGIN_LOADING gstplugin.c:317:_priv_gst_plugin_initialize: registering 0 static plugins
0:00:00.003604365 17501 0x559b121c00 INFO GST_PLUGIN_LOADING gstplugin.c:225:gst_plugin_register_static: registered static plugin “staticelements”
0:00:00.003645196 17501 0x559b121c00 INFO GST_PLUGIN_LOADING gstplugin.c:227:gst_plugin_register_static: added static plugin “staticelements”, result: 1
0:00:00.003702987 17501 0x559b121c00 INFO GST_REGISTRY gstregistry.c:1727:ensure_current_registry: reading registry cache: /home/jetson/.cache/gstreamer-1.0/registry.aarch64.bin
0:00:00.035098668 17501 0x559b121c00 INFO GST_REGISTRY gstregistrybinary.c:621:priv_gst_registry_binary_read_cache: loaded /home/jetson/.cache/gstreamer-1.0/registry.aarch64.bin in 0,031326 seconds
0:00:00.035242954 17501 0x559b121c00 INFO GST_REGISTRY gstregistry.c:1583:scan_and_update_registry: Validating plugins from registry cache: /home/jetson/.cache/gstreamer-1.0/registry.aarch64.bin
0:00:00.039660907 17501 0x559b121c00 INFO GST_REGISTRY gstregistry.c:1685:scan_and_update_registry: Registry cache has not changed
0:00:00.039699979 17501 0x559b121c00 INFO GST_REGISTRY gstregistry.c:1762:ensure_current_registry: registry reading and updating done, result = 1
0:00:00.039717802 17501 0x559b121c00 INFO GST_INIT gst.c:807:init_post: GLib runtime version: 2.56.4
0:00:00.039736042 17501 0x559b121c00 INFO GST_INIT gst.c:809:init_post: GLib headers version: 2.56.4
0:00:00.039749066 17501 0x559b121c00 INFO GST_INIT gst.c:810:init_post: initialized GStreamer successfully
0:00:00.039802825 17501 0x559b121c00 INFO GST_PIPELINE gstparse.c:337:gst_parse_launch_full: parsing pipeline description 'nvstreammux ’
0:00:00.039832969 17501 0x559b121c00 WARN GST_ELEMENT_FACTORY gstelementfactory.c:456:gst_element_factory_make: no such element factory “nvstreammux”!
0:00:00.039871848 17501 0x559b121c00 ERROR GST_PIPELINE grammar.y:816:priv_gst_parse_yyparse: no element “nvstreammux”
ERROR: pipeline could not be constructed: no element “nvstreammux”.

Seems you need to reinstall JetPack4.5.1 and Deepstream SDK 5.1.