Deepstream and Peoplenet, one person detected and counted multiple time

• Hardware Platform (Jetson / GPU)
Jetson Xavier NX and AGX
• DeepStream Version
• JetPack Version (valid for Jetson only)
• Issue Type( questions, new requirements, bugs)

Dear Nvidia family and friends,

I have a project in which I need to detect when a person appears in the field of view of the camera, and then I need to control the camera to follow that person.
I’m working with python and I was somewhat able to prepare a code and some config files to use Peoplenet.
However, although only one person shows up in front of the camera, the system counts up to 50 persons, and equally draws up to 50 bounding boxes one over the other for the same person.

Would someone have any idea what goes wrong in my code ?
Here is a gist of my code and the config files.
It’s a mix of the deepstream_python_apps deepstream_test3 and deepstream_test1_rtsp_output because I have an RTSP camera as source, and then I need to output the result into another RTSP feed, as later another jetson will perform yet other analytic tasks.
Anyway, if someone has any idea of what goes wrong, I would appreciate the help.


We have a reference config file in


Please run deepstream-app with the config file and check if the issue is present. If it works, you may replace video file source with RTSP source for your use-case.

Hello DaneLLL,

Thank you for your reply.
This brings me to another question though. In the config file you mention, there is an entry that says
However, I installed Deepstream SDK 5.1 and there is no tlt_pretrained_models directory in the models directory.
Was it provided in earlier versions of the SDK ? It’s not the only config file that mentions tlt_pretrained_models, when the directory does not exists.

I downloaded the peoplenet and the engine I find is resnet34_peoplenet_pruned.etlt_b1_gpu0_int8.engine (instead of fp16.engine).
Should I find an F16 version of the engine as well ?

Anyway, I replaced the line in the config file with resnet34_peoplenet_pruned.etlt_b1_gpu0_int8.engine and it seems to work. I also tried with the RTSP source and it work well all the same.
All that remains is to find a way to adapt this config file to my code.

Thank you again very much for your esteemed help


Please check README to download the models:


The engine is generated if it is absent. So in the first time running deepstream-app, please run with sudo.

Hello DaneLLL

Thank you for that information.
I’ll try with the newly downloaded model tonight, hopefully my problems will all be solved

I’ll get back to you with news

Hi again DaneLLL,

Thank you very much, you helped me quite a bit :-)
Now I can work on getting the metada correctly to get the bounding box coordinates and control the camera to keep the bounding box in the center of the image.


1 Like

I have a similar setup:
Hardware Platform (Jetson / GPU) Jetson Xavier NX
• DeepStream Version5.1
• JetPack Version (valid for Jetson only) 4.5.1

I tried your recommend example with the default settings:
deepstream-app -c deepstream_app_source1_peoplenet.txt

It works but the Person Count & bag count is not accurate…e.g. It says Person 12 and Bag 10 after starting…shortly afterwards says Person 49 and Bag 47.
Is this “expected”? Or how do we improve the accuracy even using the default uri=file://…/…/streams/sample_1080p_h265.mp4 before I try to use a live camera?


Hi @vincent.mcgarry ,
It is normal when the object leaves the scene and enters. Or you observe the count accumulates very quickly even the object is in the scene always?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.